C-Box of Bricks

Box of Bricks

题目描述

Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. “Look, I’ve built a wall!”, he tells his older sister Alice. “Nah, you should make all stacks the same height. Then you would have a real wall.”, she retorts. After a little consideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that all stacks are the same height afterwards. But since Bob is lazy he wants to do this with the minimum number of bricks moved. Can you help?
这里写图片描述

Input

The input consists of several data sets. Each set begins with a line containing the number n of stacks Bob has built. The next line contains n numbers, the heights hi of the n stacks. You may assume 1≤n≤50 and 1≤hi≤100.

The total number of bricks will be divisible by the number of stacks. Thus, it is always possible to rearrange the bricks such that all stacks have the same height.

The input is terminated by a set starting with n = 0. This set should not be processed.

Output

For each set, print the minimum number of bricks that have to be moved in order to make all the stacks the same height.
Output a blank line between each set.

Sample Input

6
5 2 4 1 7 5
0
#

Sample Output

5


思路

题意:给出一排由若干相同高度纸箱堆积起来的柱体,移动纸箱,将这些柱体调整为一样的高度,求移动纸箱最少的个数;
方法:开始以为很复杂,结果只要先计算出柱体的平均高度,统计出大于平均值的柱体高度总和即可;


代码

#include <cstdio>
#include <cstring>
using namespace std;
#define maxn 1005
int main()
{
    while(1)
    {
        char a[maxn],b[maxn];
        scanf("%s",a);
        if(a[0]=='#')
            break;
        else scanf("%s",b);

        int lena=strlen(a);
        int lenb=strlen(b);
        int i,j,k,num=0;

        for(i=0; i<lena-lenb+1; )
        {
            k=i;
            for(j=0; j<lenb; )
            {
                if(a[k]==b[j])
                {
                    k++,j++;
                    if(j==lenb)
                    {
                        num++;
                        i+=lenb;
                        break;
                    }
                }
                else {
                        i++;
                        break;
                }
            }
        }
        printf("%d\n",num);
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值