B - Candy Sharing Game

Candy Sharing Game

题目描述

A number of students sit in a circle facing their teacher in the center. Each student initially has an even number of pieces of candy. When the teacher blows a whistle, each student simultaneously gives half of his or her candy to the neighbor on the right. Any student, who ends up with an odd number of pieces of candy, is given another piece by the teacher. The game ends when all students have the same number of pieces of candy.
Write a program which determines the number of times the teacher blows the whistle and the final number of pieces of candy for each student from the amount of candy each child starts with.

Input

The input may describe more than one game. For each game, the input begins with the number N of students, followed by N (even) candy counts for the children counter-clockwise around the circle. The input ends with a student count of 0. Each input number is on a line by itself.

Output

For each game, output the number of rounds of the game followed by the amount of candy each child ends up with, both on one line.

Sample Input

6
36
2
2
2
2
2
11
22
20
18
16
14
12
10
8
6
4
2
4
2
4
6
8
0

Sample Output

15 14
17 22
4 8

Hint

The game ends in a finite number of steps because:
1. The maximum candy count can never increase.
2. The minimum candy count can never decrease.
3. No one with more than the minimum amount will ever decrease to the minimum.
4. If the maximum and minimum candy count are not the same, at least one student with the minimum amount must have their count increase.


思路:

题意:个分糖果的游戏,n个学生围成一圈,每个人手上有a[i]个糖果,每一轮游戏开始时,学生手中的糖果都是偶数(even number),他们都把自己手中一半的糖果分给他右边的同学。分完后手中糖果数是奇数(odd number)的,老师会给他一颗糖果。如果所有人手中的糖果数都一样 游戏结束。 输出总共进行了多少轮游戏 还有最后学生手中的糖果数。

坑:

英文障碍:偶数even number;奇数 odd number
读值顺序和传递顺序相反
题意中“每一轮游戏开始时学生手中的糖果数为偶数”是线索,应该借助这个初始条件,每次传递的时候都应该先将手中的一半传递给下一个学生,然后接受前一名同学的糖果,最后调整手中的糖果数,保持为偶数个状态。


代码

#include <stdio.h>
int allEqual(int *a,int n);

int main()
{
    int n,i;
    int a[1000];

    while(scanf("%d",&n),n)
    {
        int num=0;
        for(i=1; i<=n; i++)
        {
            scanf("%d",&a[i]);
        }

        while(notEqual(a,n))
        {
            num++;
            int y=a[n]/2;
            for(i=n; i>1; i--)
            {   //先将自己的一半送出去 ,再接受前面传递过来的
                a[i]=a[i]/2+a[i-1]/2; //逆时针传递
                if(a[i]%2)  //始终保证传递后每个人手上的苹果数都为偶数,下次拿出的一半是整数
                    a[i]++;
            }

            a[1]=a[1]/2+y;  //第一个人单独处理
            if(a[1]%2)
                a[1]++;
        }
        printf("%d %d\n",num,a[1]);
    }


    return 0;
}

int notEqual(int *a,int n)
{
    int i;
    for(i=1; i<n; i++)
        if(a[i]!=a[i+1])
            return 1;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值