W - The Circumference of the Circle

The Circumference of the Circle

题目描述

To calculate the circumference of a circle seems to be an easy task - provided you know its diameter. But what if you don’t?

You are given the cartesian coordinates of three non-collinear points in the plane.
Your job is to calculate the circumference of the unique circle that intersects all three points.

Iutput

For each test case, print one line containing one real number telling the circumference of the circle determined by the three points. The circumference is to be printed accurately rounded to two decimals. The value of pi is approximately 3.141592653589793.

Output

For each test case, print one line containing one real number telling the circumference of the circle determined by the three points. The circumference is to be printed accurately rounded to two decimals. The value of pi is approximately 3.141592653589793.

Sample Input

0.0 -0.5 0.5 0.0 0.0 0.5
0.0 0.0 0.0 1.0 1.0 1.0
5.0 5.0 5.0 7.0 4.0 6.0
0.0 0.0 -1.0 7.0 7.0 7.0
50.0 50.0 50.0 70.0 40.0 60.0
0.0 0.0 10.0 0.0 20.0 1.0
0.0 -500000.0 500000.0 0.0 0.0 500000.0

Sample Output

3.14
4.44
6.28
31.42
62.83
632.24
3141592.65


思路:

用海伦公式来求面积,然后根据面积和周长之间的关系求外接圆的半径;


代码

#include <cstdio>
#include <cmath>
using namespace std;
#define pi 3.141592653589793
double func(double x1,double y1,double x2,double y2)
{
    double temp=abs(x1-x2)*abs(x1-x2)+abs(y1-y2)*abs(y1-y2);
    return sqrt(temp);
}
int main()
{
    double x1,y1,x2,y2,x3,y3;
    while(scanf("%lf%lf%lf%lf%lf%lf",&x1,&y1,&x2,&y2,&x3,&y3)!=EOF){
        double l1=func(x1,y1,x2,y2);
        double l2=func(x2,y2,x3,y3);
        double l3=func(x1,y1,x3,y3);
        double l=(l1+l2+l3)/2;
        double temp=l*(l-l1)*(l-l2)*(l-l3);
        double r=l1*l2*l3/(4*sqrt(temp));
        printf("%.2f\n",2*r*pi);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值