E - 01背包

E - 01背包

题目描述

Bessie has gone to the mall’s jewelry store and spies a charm bracelet. Of course, she’d like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a ‘desirability’ factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Iutput

  • Line 1: Two space-separated integers: N and M
  • Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

  • Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23


思路:

题意:大家很熟悉的01背包问题;
要求用动规来做,所以可以把问题分解成背包容量为n时所能装下的最大的价值 c[j]=max(c[j],c[j-w[i]]+p[i]);


代码

#include<cstdio>
using namespace std;
int max(int x,int y)
{
    return x>y?x:y;
}
int main()
{
    int n,m,i,j;
    int w[4000],p[4000];
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        int c[20000]={0};//赋零值,下面比较用
        for(i=1;i<=n;i++)
            scanf("%d%d",&w[i],&p[i]);
        for(i=1;i<=n;i++)//循环n件物品
            for(j=m;j>=w[i];j--)//循环重量,0到m,不断比较加上第i件物品
                                //与不加上第i件物品的价值,值大的赋值给c[j]
                c[j]=max(c[j],c[j-w[i]]+p[i]);
        printf("%d\n",c[m]);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值