【算法竞赛入门经典】类似于最优矩阵链乘的动态规划 例题9-9 UVa10003

【算法竞赛入门经典】类似于最优矩阵链乘的动态规划 例题9-9 UVa10003

例题UVa140003

You have to cut a wood stick into pieces. The most affordable company, The Analog Cutting Machinery,Inc. (ACM), charges money according to the length of the stick being cut. Their procedure of work requires that they only make one cut at a time.
It is easy to notice that different selections in the order of cutting can led to different prices. For
example, consider a stick of length 10 meters that has to be cut at 2, 4 and 7 meters from one end.There are several choices. One can be cutting rst at 2, then at 4, then at 7. This leads to a price of 10 + 8 + 6 = 24 because the rst stick was of 10 meters, the resulting of 8 and the last one of 6. Another choice could be cutting at 4, then at 2, then at 7. This would lead to a price of 10 + 4 + 6 = 20, which is a better price.
Your boss trusts your computer abilities to nd out the minimum cost for cutting a given stick.

Input

The input will consist of several input cases. The rst line of each test case will contain a positive number l that represents the length of the stick to be cut. You can assume l < 1000. The next line will contain the number n (n < 50) of cuts to be made.
The next line consists of n positive numbers ci (0 < ci < l) representing the places where the cuts have to be done, given in strictly increasing order.
An input case with l = 0 will represent the end of the input.

Output

You have to print the cost of the optimal solution of the cutting problem, that is the minimum cost of cutting the given stick. Format the output as shown below.

Sample Input

100
3
25 50 75
10
4
4 5 7 8
0

Sample Output

The minimum cutting is 200.
The minimum cutting is 22.

分析

类似于最优矩阵链乘,都是有最后一个最优状态继而将一个大问题分解为两个相同的自问题,求最优子结构,一层层往下递归寻找出最优解。【因为子问题之间互不影响且不影响大问题】
如果要改成递推的话,要从j-i从小往大递增的顺序写,因为先求出子问题才能求出上一层的问题。
另外,其实不用像本代码一样记录每个长度点,只需要记录下有切割位置的点的位置a[i],每一段的长度可以有a[]之差求得

样例实现代码

#include<iostream>
#include<cstring>
#include<algorithm>
#define maxn 1000+5
#define INF 1000000
using namespace std;
int length, num;
int d[maxn][maxn];
int cut[maxn], cutsum[maxn];
int dp(int i, int j) {
    if (d[i][j] != -1)
        return d[i][j];
    int cp = cutsum[j - 1] - cutsum[i-1];
    if (cp == 0) {
        d[i][j] = 0;
        return 0;
    }
    int poi = i, ans = INF;
    while (cp) {
        if (cut[poi] == 1) {
            cp--;
            ans = min(ans, dp(i,poi)+dp(poi+1,j));
        }
        poi++;
    }
    d[i][j] = ans + j - i + 1;
    return d[i][j];
}
int main() {
    while (cin >> length && length) {
        cin >> num;
        int temp;
        memset(cut, 0, sizeof(cut));
        for (int i = 0; i < num; i++) {
            cin >> temp;
            cut[temp] = 1;
        }
        for (int i = 1; i <= length; i++)
            cutsum[i] = cutsum[i - 1] + cut[i];
        memset(d, -1, sizeof(d));
        int ans = dp(1, length);
        cout << "The minimum cutting is " << ans << "." << endl;
    }
    return 0;
}

结果

这里写图片描述

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值