POJ 1651 (最优矩阵链乘)

Multiplication Puzzle
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9575 Accepted: 5954

Description

The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row. 

The goal is to take cards in such order as to minimize the total number of scored points. 

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring 
10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000

If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be 
1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.

Input

The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.

Output

Output must contain a single integer - the minimal score.

Sample Input

6
10 1 50 50 20 5

Sample Output

3650

分析:最优链乘矩阵的变形(没有明确说明是矩阵,输入有点差别,但做法一样)

状态方程:dp(i,j)=min(dp(i,k)+dp(k+1,j)+v(i)*v(k+1)*v(j+1));  表示从i到j的最低消耗(i,j表示第几个矩阵,矩阵的总个数t=n-1;)最后答案就是dp(1,t);递推求解

AC代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define INF 2147483647
const int maxn=100+10;
int dp[maxn][maxn];
int v[maxn];
int n;

int main(){
	while(scanf("%d",&n)==1){
		for(int i=1;i<=n;i++)
		 {
		 scanf("%d",&v[i]);
		 dp[i][i]=0;
		}
		
		int t=n-1;
		for(int len=2;len<=t;len++)  //矩阵的长度 
		 for(int i=1;i<=t-len+1;i++)  //起始位置 
		  {
		  	int j=i+len-1;  //终点位置 
		  	dp[i][j]=INF;
		    for(int k=i;k<j;k++)
		     dp[i][j]=min(dp[i][j],dp[i][k]+dp[k+1][j]+v[i]*v[k+1]*v[j+1]);  
		}
		
		printf("%d\n",dp[1][t]);
	}
	return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

柏油

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值