hdu5540

Secrete Master Plan

Master Mind KongMing gave Fei Zhang a secrete master plan stashed in a pocket. The plan instructs how to deploy soldiers on the four corners of the city wall. Unfortunately, when Fei opened the pocket he found there are only four numbers written in dots on a piece of sheet. The numbers form 2×2
matrix, but Fei didn’t know the correct direction to hold the sheet. What a pity!
Given two secrete master plans. The first one is the master’s original plan. The second one is the plan opened by Fei. As KongMing had many pockets to hand out, he might give Fei the wrong pocket. Determine if Fei receives the right pocket.
在这里插入图片描述

Input
The first line of the input gives the number of test cases,
T(1≤T≤104). Ttest cases follow. Each test case contains 4 lines. Each line contains two integers
ai0 and ai1(1≤ai0,ai1≤100). The first two lines stands for the original plan, the 3rdand 4th line stands for the plan Fei opened.

Output
For each test case, output one line containing “Case #x: y”, where x is the test case number
(starting from 1) and y is either “POSSIBLE” or “IMPOSSIBLE” (quotes for clarity).

Sample Input
4
1 2
3 4
1 2
3 4

1 2
3 4
3 1
4 2

1 2
3 4
3 2
4 1

1 2
3 4
4 3
2 1

Sample Output
Case #1: POSSIBLE
Case #2: POSSIBLE
Case #3: IMPOSSIBLE
Case #4: POSSIBLE

Source
The 2015 China Collegiate Programming Contest

题意:

将数据按0度,90度,180度,270度旋转后各数据
能进行相对应的匹配即输出“POSSIBLE”否则输出“IMPOSSIBLE”,
由于本题只要求输入2x2的矩阵,直接定义8个变量存两组数据即可.
暴力求解!

AC代码

#include"iostream"
using namespace std;
int main()
{
	int t;
	int num=1;
	int x1,x2,x3,x4,y1,y2,y3,y4;
	cin>>t;
	while(t--)
	{
		cin>>x1>>x2>>x4>>x3;//注意输入:先输入x4再输入x3
		cin>>y1>>y2>>y4>>y3;//同上,这样才有顺序!
		if(x1==y1&&x2==y2&&x3==y3&&x4==y4)
			cout<<"Case #"<<num<<": POSSIBLE"<<endl;
		else if(x1==y2&&x2==y3&&x3==y4&&x4==y1)
			cout<<"Case #"<<num<<": POSSIBLE"<<endl;
		else if(x1==y3&&x2==y4&&x3==y1&&x4==y2)
			cout<<"Case #"<<num<<": POSSIBLE"<<endl;
		else if(x1==y4&&x2==y1&&x3==y2&&x4==y3)
			cout<<"Case #"<<num<<": POSSIBLE"<<endl;
		else
			cout<<"Case #"<<num<<": IMPOSSIBLE"<<endl;
		num++;
	}
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值