竖式问题

问题描述:
找出形如 abc*de (三位数乘以两位数) 的算式,使得在完整的竖式中,所有数字属于一个特定的数字集合。输入数字集合 (相邻数字之间没有空格),输出所有竖式。每个竖式前应有编号,之后应有一个空行。最后输出解的总数。

样例输入:

2357

样例输出:

  本题看了很久才明白题目含义:如输入2357,即特定的数字集合为{2,3,5,7}。第一行775属于7,5;第二行33属于3;第三行2325属于2,3,5依次类推。发现输出都属于该“数字集合”,满足要求输出。

#include <stdio.h>
#include <string.h>

int main()
{
    int count = 0;
    char s[20], buf[99];
    scanf("%s", s);
    for(int abc = 111; abc <= 999; abc++)
        for(int de = 11; de <= 99; de++)
    {
        int x = abc*(de%10), y = abc*(de/10), z = abc*de;
        sprintf(buf, "%d%d%d%d%d", abc, de, x, y, z);
        int ok = 1;
        for(int i = 0; i < strlen(buf); i++)
            if(strchr(s, buf[i]) == NULL) ok = 0;
        if(ok)
        {
            printf("<%d>\n ", ++count);
            printf("%5d\nX%4d\n-----\n%5d\n%4d\n-----\n%5d\n\n", abc, de, x, y ,z);
        }
    }
    printf("The number of solutions = %d\n", count);
    int z;
    printf("%d\n", strlen(buf));
    while(1)
    {
        scanf("%d", &z);
        printf("%d\n", buf[z]);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值