Ants
Time Limit: 1000MS | Memory Limit: 30000K | |
Total Submissions: 21297 | Accepted: 8744 |
Description
An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.
Input
The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.
Output
For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time.
Sample Input
2 10 3 2 6 7 214 7 11 12 7 13 176 23 191
Sample Output
4 8
38 207
大体意思是蚂蚁走杆,两蚂蚁碰头后会反向行走,走到杆头会掉下去,求所有蚂蚁都掉下去的最大和最小时间。
思维题目,需要想到一点就是两只蚂蚁在碰头时分别反向走的路程与两只蚂蚁直接向前走的路程相同,即两只蚂蚁在碰头时反向走可以看做两只蚂蚁碰头后仍保持原方向继续行走,以此类推,问题便转化为每只蚂蚁均向前走时所用时间最长与最短。所以所用最短时间为每只蚂蚁所走最短路程的集合里的最大值,所用最长时间为每只蚂蚁所走最长路程集合里的最大值。
代码如下
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstdlib>
#include <cstring>
using namespace std;
int a[1000005];
int Min(int a,int b)
{
return a<b?a:b;
}
int Max(int a,int b)
{
return a>b?a:b;
}
int main()
{
int n;
int l;
int x;
scanf("%d",&x);//一共有几组数据需要计算
while(x--)
{
scanf("%d%d",&l,&n);//长度和组数
int mit=0,mat=0;//最大时间和最小时间
for(int i=0; i<n; i++)
{
scanf("%d",&a[i]);
mit=Max(mit,Min(a[i],l-a[i]));//求最小时间
mat=Max(mat,Max(a[i],l-a[i]));//求最大时间
}
printf("%d %d\n",mit,mat);
}
return 0;
}
需要注意的一个问题就是此题用cin会超时,用scanf就可以通过了。