B-number HDU - 3652 [数位DP]

B-number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7701    Accepted Submission(s): 4521


Problem Description
A wqb-number, or B-number for short, is a non-negative integer whose decimal form contains the sub- string "13" and can be divided by 13. For example, 130 and 2613 are wqb-numbers, but 143 and 2639 are not. Your task is to calculate how many wqb-numbers from 1 to n for a given integer n.
 

Input
Process till EOF. In each line, there is one positive integer n(1 <= n <= 1000000000).
 

Output
Print each answer in a single line.
 

Sample Input
  
  
13 100 200 1000
 

Sample Output
  
  
1 1 2 2
 

Author
wqb0039
 

Source
 

Recommend
lcy

思路: 数位DP ,

13的倍数模拟除法过程

包含13用标记记录


#include <bits/stdc++.h>
#define INF 0x3f3f3f3f
//#define MOD 1000000007
#define bug1 cout <<"bug1"<<endl
#define bug2 cout <<"bug2"<<endl
#define bug3 cout <<"bug3"<<endl
using namespace std;
typedef long long ll;

const int MAX_N=2e5+5;
int bit[50];
int dp[50][20][5];

///有13并且可以被13整除
ll dfs(int pos,int mod,int have,bool lead,bool limit){
    if(pos==-1) return (mod==0&&have==2);
    if(!limit && !lead && dp[pos][mod][have]!=-1)   return dp[pos][mod][have];
    int up=limit ? bit[pos] : 9;
    ll ans=0;
    for(int i=0;i<=up;i++){
        int tempmode=(mod*10+i)%13; //模拟除法过程,13的倍数
        int temphave=have;
        if(have==0&&i==1)   temphave=1;
        else if(have==0&&i!=1)  temphave=have=0;
        else if(have==1 && i==3)    temphave=2;
        else if(have==1 && i==1)    temphave=1;
        else if(have==1 && i!=1)    temphave=0;
        ans+=dfs(pos-1,tempmode,temphave,i==0&&lead,limit&&bit[pos]==i);
    }
    if(!limit && !lead) dp[pos][mod][have]=ans;
    return ans;
}

ll solve(ll n){
    int pos=0;
    while(n){
        bit[pos++]=n%10;
        n/=10;
    }
    return dfs(pos-1,0,0,true,true);//最高位肯定有限制,有没有前导0是根据题意来的,但是题目如果考虑前导0
}//一定不会出错.因为只是把前导0的情况不记录到DP中 .╰(*°▽°*)╯ 亲测!

int main(void){
    ll n;
    while((scanf("%lld",&n))!=EOF){
        memset(dp,-1,sizeof(dp));
        printf("%lld\n",solve(n));
    }
}

其实都是暴力枚举+记忆化搜索的恶心套路啊!


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值