HDU3652 B-number(数位DP)

B-number

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4565 Accepted Submission(s): 2617

Problem Description
A wqb-number, or B-number for short, is a non-negative integer whose decimal form contains the sub- string “13” and can be divided by 13. For example, 130 and 2613 are wqb-numbers, but 143 and 2639 are not. Your task is to calculate how many wqb-numbers from 1 to n for a given integer n.

Input
Process till EOF. In each line, there is one positive integer n(1 <= n <= 1000000000).

Output
Print each answer in a single line.

Sample Input
13
100
200
1000

Sample Output
1
1
2
2

Author
wqb0039

Source
2010 Asia Regional Chengdu Site —— Online Contest

Recommend
lcy | We have carefully selected several similar problems for you: 3651 3655 3654 3653 3659

数位DP模板题

#include "cstring"
#include "cstdio"
#include "string.h"
#include "iostream"
#include "cmath"
using namespace std;
int num[20];
int dp[20][20][20][2];//0 don't have 13, 1 have 13
int dfs(int pos,int mod,int pre,int have,int over)
{
    if(pos<0)
        return (mod==0&&have);
    if(dp[pos][mod][pre][have]!=-1&&!over)
        return dp[pos][mod][pre][have];
    int last=over?num[pos]:9;
    int ans=0;
    for(int i=0;i<=last;i++)
    {

        int temp=10*mod;
        temp+=i;
        temp%=13;
        if(pre==1&&i==3)
            ans+=dfs(pos-1,temp,i,true,over&&i==last);
        else
            ans+=dfs(pos-1,temp,i,have,over&&i==last);

    }
    if(!over)
        dp[pos][mod][pre][have]=ans;
    return ans;

}

int solve(int n)
{
    int len=0;
    while(n)
    {
        num[len++]=n%10;
        n/=10;
    }
    return dfs(len-1,0,0,false,true);
}

int main()
{
    int n;
    memset(dp,-1,sizeof(dp));
    while(~scanf("%d",&n))
    {
        printf("%d\n",solve(n));
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值