Hat’s Words HDU - 1247 [字典树]

Hat’s Words

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17088    Accepted Submission(s): 6141


Problem Description
A hat’s word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.
You are to find all the hat’s words in a dictionary.
 

Input
Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 50,000 words.
Only one case.
 

Output
Your output should contain all the hat’s words, one per line, in alphabetical order.
 

Sample Input
 
 
aahathathatwordhzieeword
 

Sample Output
 
 
ahathatword
 

Author
戴帽子的
 

Recommend
Ignatius.L

思路:给一个字典,输出这些词,满足条件: 该词可以拆分成两个字典中的词.

注意判断不是前缀而是字典中的词

复杂度:O(n*len)


#include <bits/stdc++.h>
#pragma comment(linker, "/STACK:102400000,102400000")
#define INF 0x3f3f3f3f
#define MOD 1000000007
#define bug1 cout <<"bug1"<<endl
#define bug2 cout <<"bug2"<<endl
#define bug3 cout <<"bug3"<<endl
using namespace std;
typedef long long ll;

struct node{
    node *next[26];
    bool flag;
    node(){
        flag=false;
        for(int i=0;i<26;i++)   next[i]=NULL;
    }
};

char str[51000][200];
node *root;

void buildtrie(char *s){
    int len=(int)strlen(s);
    node *p=root;
    for(int i=0;i<len;++i){
        int num=s[i]-'a';
        if(!p->next[num]){
            node *temp=new node;
            p->next[num]=temp;
        }
        p=p->next[num];
    }
    p->flag=true;
    return ;
}

bool findtrie(char *s){
    int len=strlen(s);
    node *p=root;
    for(int i=0;i<len;++i){
        int num=s[i]-'a';
        if(!p->next[num])   return false ;
        else{
            p=p->next[num];
        }
    }
    return p->flag;
}



int main(void){
    int num=0;  
    root=new node();
    while(scanf("%s",str[num++])!=EOF){
        buildtrie(str[num-1]);
    }
    for(int i=0;i<num;++i){
        int len=strlen(str[i]);
        for(int j=0,k;j<len-1;++j){
            char a[5000],b[5000];
            for(k=0;k<=j;++k)   a[k]=str[i][k];
            a[k]='\0';
            for(k=0;k<=len-1-j;++k)   b[k]=str[i][k+j+1];
            b[k]='\0';
//            printf("a=%s b=%s\n",a,b);
            if(findtrie(a) && findtrie(b)){
                printf("%s\n",str[i]);
                break;
            }
        }
    }
    return 0;
}



  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值