K - Kinds of Fuwas----(2015 summer training #4 (Qualifying))

K - Kinds of Fuwas
时限:2000MS     内存:65536KB     64位IO格式:%lld & %llu

问题描述

In the year 2008, the 29th Olympic Games will be held in Beijing. This will signify the prosperity of China as well as becoming a festival for people all over the world.

The official mascots of Beijing 2008 Olympic Games are Fuwa, which are named as Beibei, Jingjing, Haunhuan, Yingying and Nini. Fuwa embodies the natural characteristics of the four most popular animals in China -- Fish, Panda, Tibetan Antelope, Swallow -- and the Olympic Flame. To popularize the official mascots of Beijing 2008 Olympic Games, some volunteers make a PC game with Fuwa.

As shown in the picture, the game has a matrix of Fuwa. The player is to find out all the rectangles whose four corners have the same kind of Fuwa. You should make a program to help the player calculate how many such rectangles exist in the Fuwa matrix.


输入

Standard input will contain multiple test cases. The first line of the input is a single integer T (1 <= T <= 50) which is the number of test cases. And it will be followed by T consecutive test cases.

The first line of each test case has two integers M and N (1 <= MN <= 250), which means the number of rows and columns of the Fuwa matrix. And then there are M lines, each has N characters, denote the matrix. The characters -- 'B' 'J' 'H' 'Y' 'N' -- each denotes one kind of Fuwa.


输出

Results should be directed to standard output. The output of each test case should be a single integer in one line, which is the number of the rectangles whose four corners have the same kind of Fuwa.


样例输入

2
2 2
BB
BB
5 6
BJHYNB
BHBYYH
BNBYNN
JNBYNN
BHBYYH


样例输出

1
8


分析:给你一个m*n矩阵,问有多少个矩形小矩阵满足四个角是相同的字母?

    遍历,枚举两行,然后枚举一列,最后用组合数求解求和。


CODE:

#include <iostream>
#include <string.h>
using namespace std;

int main()
{
    int t; cin>>t;
    while(t--){
        int m,n,ans=0;;
        char mar[255][255];
        int fuwa[120];
        cin>>m>>n;
        for(int i=0;i<m;i++)
            for(int j=0;j<n;j++)
                cin>>mar[i][j];
        for(int i=0;i<m-1;i++){
            for(int j=i+1;j<m;j++){
                memset(fuwa,0,sizeof(fuwa));
                for(int k=0;k<n;k++)
                    if(mar[i][k]==mar[j][k])
                        fuwa[mar[i][k]]++;
                ans+=fuwa['B']*(fuwa['B']-1)/2;
                ans+=fuwa['J']*(fuwa['J']-1)/2;
                ans+=fuwa['H']*(fuwa['H']-1)/2;
                ans+=fuwa['Y']*(fuwa['Y']-1)/2;
                ans+=fuwa['N']*(fuwa['N']-1)/2;
            }
        }
        cout<<ans<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值