J - A Bit Fun-----(2015 summer training #9)

J - A Bit Fun
时限:2500MS     内存:32768KB     64位IO格式:%I64d & %I64u

问题描述

There are n numbers in a array, as a  0, a  1 ... , a  n-1, and another number m. We define a function f(i, j) = a  i|a  i+1|a  i+2| ... | a  j . Where "|" is the bit-OR operation. (i <= j) 
The problem is really simple: please count the number of different pairs of (i, j) where f(i, j) < m.
 

输入

The first line has a number T (T <= 50) , indicating the number of test cases. 
For each test case, first line contains two numbers n and m.(1 <= n <= 100000, 1 <= m <= 2  30) Then n numbers come in the second line which is the array a, where 1 <= a  i <= 2  30.
 

输出

For every case, you should output "Case #t: " at first, without quotes. The  t is the case number starting from 1. 
Then follows the answer.
 

样例输入

     
     
2 3 6 1 3 5 2 4 5 4
 

样例输出

     
     
Case #1: 4 Case #2: 0

分析:或运算只会越计算越大,值是一个递增的,所以中间必有一个分界点,找到就ok了。


CODE:

#include <iostream>
using namespace std;

int main()
{
    int t,cases=0,arr[100005];
    cin>>t;
    while(t--){
        int n,m;
        cin>>n>>m;
        cases++;
        for(int i=0;i<n;i++)
            cin>>arr[i];
        cout<<"Case #"<<cases<<": ";
        int cnt=0;
        long long ans;
        for(int i=0;i<n;i++){
            ans=0;
            for(int j=i;j<n;j++){
                ans=ans|arr[j];
                cnt++;
                if(ans>=m){
                    cnt--;
                    break;
                }
            }
        }
        cout<<cnt<<endl;
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值