HDU 5241 Friends

Friends

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 515    Accepted Submission(s): 258


Problem Description
Mike has many friends. Here are nine of them: Alice, Bob, Carol, Dave, Eve, Frank, Gloria, Henry and Irene. 

Mike is so skillful that he can master  n  languages (aka. programming languages).

His nine friends are all weaker than he. The sets they can master are all subsets of Mike's languages.

But the relations between the nine friends is very complex. Here are some clues.

1. Alice is a nice girl, so her subset is a superset of Bob's.
2. Bob is a naughty boy, so his subset is a superset of Carol's.
3. Dave is a handsome boy, so his subset is a superset of Eve's.
4. Eve is an evil girl, so her subset is a superset of Frank's.
5. Gloria is a cute girl, so her subset is a superset of Henry's.
6. Henry is a tall boy, so his subset is a superset of Irene's.
7. Alice is a nice girl, so her subset is a superset of Eve's.
8. Eve is an evil girl, so her subset is a superset of Carol's.
9. Dave is a handsome boy, so his subset is a superset of Gloria's.
10. Gloria is a cute girl, so her subset is a superset of Frank's.
11. Gloria is a cute girl, so her subset is a superset of Bob's.

Now Mike wants to know, how many situations there might be.
 

Input
The first line contains an integer  T ( T20 ) denoting the number of test cases.

For each test case, the first line contains an integer  n ( 0n3000 ), denoting the number of languages.

 

Output
For each test case, output ''Case #t:'' to represent this is the t-th case. And then output the answer.
 

Sample Input
  
  
2 0 2
 

Sample Output
  
  
Case #1: 1 Case #2: 1024
 

Source


分析:每一种语言具有相互对立性,就能清楚答案其实是语言数量的若干次方,然后就能根据样例f(0)=1,f(2)=1024轻易推出这道题的答案就是32^n。

  大数乘法,用java方便。


CODE:

import java.io.*;
import java.math.*;
import java.util.*;
public class Main{
    public static void main(String[] args){
        Scanner read=new Scanner(System.in);
        int T;
        T=read.nextInt();
        for(int Case=1;Case<=T;Case++)
        {
            int n=read.nextInt();
            System.out.printf("Case #%d: ",Case);
            System.out.println(BigInteger.valueOf(32).pow(n));
        }
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值