Zball in Tina Town-----(BestCoder Round #51 (div.2))

Zball in Tina Town

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)


Problem Description
Tina Town is a friendly place. People there care about each other.

Tina has a ball called zball. Zball is magic. It grows larger every day. On the first day, it becomes  1  time as large as its original size. On the second day,it will become  2  times as large as the size on the first day. On the n-th day,it will become  n  times as large as the size on the (n-1)-th day. Tina want to know its size on the (n-1)-th day modulo n.
 

Input
The first line of input contains an integer  T , representing the number of cases.

The following  T  lines, each line contains an integer  n , according to the description.
T105,2n109
 

Output
For each test case, output an integer representing the answer.
 

Sample Input
  
  
2 3 10
 

Sample Output
  
  
2 0
 

Source


分析:找规律,这题就是求 (n-1)!modn(n−1)!  mod  n。如果nn为合数,显然答案为0.如果nn为素数,那么由威尔逊定理可得答案为 n-1n−1。所以就在于快速判断一个数是否为素数。


CODE:

#include <iostream>
#include <cstdio>
#include <string.h>
#include <cmath>
using namespace std;

int xindalamu(int a)
{
    if(a%2==0) return 0;

    int aa=(a-1)>>1;
    int half=(int)sqrt(aa/2.0);

    for(int i=1;i<=half;i++)
    {
        if((aa-i)%(2*i+1)==0) return 0;
    }

    return 1;
}

int main()
{
    int t; cin>>t;
    int a[5]={0,0,1,2,2};
    while(t--){
        int n;
        cin>>n;
        if(n<5){
            printf("%d\n",a[n]);
            continue;
        }
        if(xindalamu(n))
            printf("%d\n",n-1);
        else
            printf("0\n");
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值