BestCoder Round #51 (div.2) 1001 找规律+判素数

Zball in Tina Town

Accepts: 356
Submissions: 2463
Time Limit: 3000/1500 MS (Java/Others)
Memory Limit: 262144/262144 K (Java/Others)
Problem Description

Tina Town is a friendly place. People there care about each other.

Tina has a ball called zball. Zball is magic. It grows larger every day. On the first day, it becomes 111 time as large as its original size. On the second day,it will become 222 times as large as the size on the first day. On the n-th day,it will become nnn times as large as the size on the (n-1)-th day. Tina want to know its size on the (n-1)-th day modulo n.

Input

The first line of input contains an integer TTT, representing the number of cases.

The following TTT lines, each line contains an integer nnn, according to the description.T≤105,2≤n≤109 T \leq {10}^{5},2 \leq n \leq {10}^{9} T105,2n109

Output

For each test case, output an integer representing the answer.

Sample Input
2
3
10
Sample Output
2
0
 
 
题意:求n-1的阶乘%n
分析:写几个就能找出规律来,n>5,如果n是素数,那么输出n-1,否则输出0

时间紧,代码没优化,AC了,356分之一,嘿嘿

#include<iostream>
#include<string.h>
#include<stdio.h>
#include<algorithm>
#include<cmath>
using namespace std;
bool comp(unsigned long long  num)
{
     if (num <= 2)
     {
         return num == 2;
     }

     if (num % 2 == 0)
     {
         return false;
     }
     unsigned long  n = sqrt(num);

     for (int i = 3; i <= n; i+=2)
     {
         if (num % i == 0)
         {
             return false;
         }
     }
     return true;
}
int main()
{
    int T;
    unsigned long long n;
    cin>>T;
    while(T--){
        scanf("%I64d",&n);
       unsigned long long result = 1;
       if(n<5){
        for( int i = 1; i < n ; ++i )
        {
            result *= i;
        }
        cout<<result%n<<endl;
       }
       else if(comp(n))cout<<n-1<<endl;
       else printf("0\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值