hdu3183__A Magic Lamp(RMQ模板题)

2 篇文章 0 订阅
1 篇文章 0 订阅

A Magic Lamp

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2298    Accepted Submission(s): 909


Problem Description
Kiki likes traveling. One day she finds a magic lamp, unfortunately the genie in the lamp is not so kind. Kiki must answer a question, and then the genie will realize one of her dreams. 
The question is: give you an integer, you are allowed to delete exactly m digits. The left digits will form a new integer. You should make it minimum.
You are not allowed to change the order of the digits. Now can you help Kiki to realize her dream?
 

Input
There are several test cases.
Each test case will contain an integer you are given (which may at most contains 1000 digits.) and the integer m (if the integer contains n digits, m will not bigger then n). The given integer will not contain leading zero.
 

Output
For each case, output the minimum result you can get in one line.
If the result contains leading zero, ignore it. 
 

Sample Input
  
  
178543 4 1000001 1 100001 2 12345 2 54321 2
 

Sample Output
  
  
13 1 0 123 321
 

Source
 

题意:

*************/

给出一串数字,要求删除m个数字使剩下数字按原来的顺序的组成的数最小。简单的rmq查询,这里使用的是st算法

/*************

代码如下:

#include<stdio.h>
#include<string.h>
#include<math.h>
char ch[1005], ans[1005];
int f[1005][1005];
int minn(int i, int j)
{
    return ch[i] <= ch[j] ? i : j;
}
void st(int n)
{
    int i, j;
    int k = (int)(log(double(n)) / log(2.0));
    for(i = 0; i < n; i++)
    {
        f[i][0] = i;
    }
    for(j = 1; j <= k; j++)
    {
        for(i = 0; i + (1 << j) - 1 < n; ++i)
        {
            int m = i + (1 << (j - 1));
            f[i][j] = minn(f[i][j - 1], f[m][j - 1]);
        }
    }
}
int rmq(int i, int j)		//查询区间i到j上最小值
{
    int k = (int)(log(double(j - i + 1)) / log(2.0));
    int t, m;
    m = j - (1 << k) + 1;
    return minn(f[i][k], f[m][k]);
}
int main()
{
    int m, k, n, kk;
    int maxn = 1000000;
    while(~scanf("%s%d", ch, &m))
    {
        int len = strlen(ch);
        if(len <= m)
        {
            printf("0\n");
            continue;
        }
        st(len);
        n = len - m;
        k = 0;
        for(int j = 1; j <= n; j++)	//查询len-m个最小的数存到ans中
        {
            kk = rmq(k, m + j - 1);
            k = kk + 1;
            ans[j] = ch[kk];
        }
        int flag = 0;
        for(int j = 1; j <= n; j++)
        {
            if(ans[j] != '0')
            {
                printf("%c", ans[j]);
                flag = 1;
            }
            else if(flag || j == n)
            {
                printf("%c", ans[j]);
            }
        }
        printf("\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值