HDU5443 The Water Problem -RMQ模板题

题目链接:

http://acm.hdu.edu.cn/showproblem.php?pid=5443

The Water Problem

Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 3387    Accepted Submission(s): 2417

Problem Description

In Land waterless, water is a very limited resource. People always fight for the biggest source of water. Given a sequence of water sources with a1,a2,a3,...,anrepresenting the size of the water source. Given a set of queries each containing 2 integers l and r, please find out the biggest water source between al and ar. 

Input

First you are given an integer T(T≤10) indicating the number of test cases. For each test case, there is a number n(0≤n≤1000) on a line representing the number of water sources. n integers follow, respectively a1,a2,a3,...,an, and each integer is in {1,...,106}. On the next line, there is a number q(0≤q≤1000)representing the number of queries. After that, there will be q lines with two integers l and r(1≤l≤r≤n) indicating the range of which you should find out the biggest water source.

Output

For each query, output an integer representing the size of the biggest water source.

Sample Input

3

1

100

1

1 1

5

1 2 3 4 5

5

1 2

1 3

2 4

3 4

3 5

3

1 999999 1

4

1  1

1 2

2 3

3 3

Sample Output

100

2

3

4

4

5

1

999999

999999

1

题意:

T组测试数据,每组测试数据,有n个数组元素,接下来q次询问,问[l,r]内的最大值

思路:

直接的RMQ模板题

This is the code

#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<iostream>
#include<iomanip>
#include<list>
#include<map>
#include<queue>
#include<sstream>
#include<stack>
#include<string>
#include<set>
#include<vector>
using namespace std;
#define PI acos(-1.0)
#define EPS 1e-8
#define MOD 1e9+7
#define LL long long
#define ULL unsigned long long     //1844674407370955161
#define INT_INF 0x7f7f7f7f      //2139062143
#define LL_INF 0x7f7f7f7f7f7f7f7f //9187201950435737471
// ios::sync_with_stdio(false);
// 那么cin, 就不能跟C的 scanf,sscanf, getchar, fgets之类的一起使用了。
const int dr[]= {0, 0, -1, 1, -1, -1, 1, 1};
const int dc[]= {-1, 1, 0, 0, -1, 1, -1, 1};
const int MAXN=1000+50;
int d[MAXN];
int dmax[MAXN][20];
int dmin[MAXN][20];

void init(int n)//初始化
{
    for(int i=1; i<=n; i++)
    {
        dmax[i][0]=d[i];
        dmin[i][0]=d[i];
    }
    for(int j=1 ; (1<<j)<=n ; j++)
    {
        for(int i=1; i+(1<<j)-1 <=n; i++)
        {
            dmax[i][j]=max(dmax[i][j-1],dmax[i+(1<<(j-1))][j-1]);
            dmin[i][j]= min( dmin[i][j-1],dmin[i+(1<<(j-1))][j-1] );
        }
    }
}
int getMax(int L,int R)//查询最大值
{
    int k=0;
    while((1<<(k+1))<=R-L+1)
        k++;
    return max(dmax[L][k], dmax[R-(1<<k)+1][k]);
}
int getMin(int L,int R)//查询最小值
{
    int k=0;
    while( (1<<(k+1)) <=R-L+1)
        k++;
    return min(dmin[L][k],dmin[R-(1<<k)+1][k]);
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,q;
        scanf("%d",&n);
        for(int i=1; i<=n; i++)
            scanf("%d",&d[i]);
        init(n);
        scanf("%d",&q);
        while(q--)
        {
            int L,R;
            scanf("%d%d",&L,&R);
            printf("%d\n",getMax(L,R));
        }
    }
    return 0;
}



 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值