hdu5475__An easy problem(线段树单点更新)

An easy problem

Time Limit: 8000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 593    Accepted Submission(s): 342


Problem Description
One day, a useless calculator was being built by Kuros. Let's assume that number X is showed on the screen of calculator. At first, X = 1. This calculator only supports two types of operation.
1. multiply X with a number.
2. divide X with a number which was multiplied before.
After each operation, please output the number X modulo M.
 

Input
The first line is an integer T( 1T10 ), indicating the number of test cases.
For each test case, the first line are two integers Q and M. Q is the number of operations and M is described above. ( 1Q105,1M109 )
The next Q lines, each line starts with an integer x indicating the type of operation.
if x is 1, an integer y is given, indicating the number to multiply. ( 0<y109 )
if x is 2, an integer n is given. The calculator will divide the number which is multiplied in the nth operation. (the nth operation must be a type 1 operation.)

It's guaranteed that in type 2 operation, there won't be two same n.
 

Output
For each test case, the first line, please output "Case #x:" and x is the id of the test cases starting from 1.
Then Q lines follow, each line please output an answer showed by the calculator.
 

Sample Input
  
  
1 10 1000000000 1 2 2 1 1 2 1 10 2 3 2 4 1 6 1 7 1 12 2 7
 

Sample Output
  
  
Case #1: 2 1 2 20 10 1 6 42 504 84
 

Source
 


题意:输入T代表T组样例,每组输入一个q,m分别代表有q个操作,每次操作后结果要对m取余。每次操作输入两个数a,b,若a=1,则代表结果是要乘以b,若a=2,则代表结果要除以第b次操作输入的'b'。

想法:线段树,把q次操作当成是q个节点,第i次操作时,当a=1时,把i节点对应的值更新成b,当a=2时,把b节点对应的值更新成1。

代码如下:

#include<cstdio>
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define maxn 111111
typedef long long ll;
int T,q,M;
ll col[maxn<<2];
void pushup(int rt)
{
    col[rt]=col[rt<<1]*col[rt<<1|1]%M;
}
void build(int l,int r,int rt)
{
    if(l==r)
    {
        col[rt]=1;
        return ;
    }
    int m=(l+r)>>1;
    build(lson);
    build(rson);
    pushup(rt);
}
void update(int p,int c,int l,int r,int rt)
{
    if(l==r&&l==p)
    {
        col[rt]=c;
        return ;
    }
    int m=(l+r)>>1;
    if(p<=m) update(p,c,lson);
    else update(p,c,rson);
    pushup(rt);
}
int main()
{
    int a,b,cas=1;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&q,&M);
        build(1,q,1);
        printf("Case #%d:\n",cas++);
        for(int i=1; i<=q; i++)
        {
            scanf("%d%d",&a,&b);
            if(a==1)
            {
                update(i,b,1,q,1);
            }
            else if(a==2)
            {
                update(b,1,1,q,1);
            }
            printf("%d\n",col[1]);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值