hdu 5651

xiaoxin juju needs help

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1376    Accepted Submission(s): 392


Problem Description
As we all known, xiaoxin is a brilliant coder. He knew **palindromic** strings when he was only a six grade student at elementry school.

This summer he was working at Tencent as an intern. One day his leader came to ask xiaoxin for help. His leader gave him a string and he wanted xiaoxin to generate palindromic strings for him. Once xiaoxin generates a different palindromic string, his leader will give him a watermelon candy. The problem is how many candies xiaoxin's leader needs to buy?
 

Input
This problem has multi test cases. First line contains a single integer  T(T20)  which represents the number of test cases.
For each test case, there is a single line containing a string  S(1length(S)1,000) .
 

Output
For each test case, print an integer which is the number of watermelon candies xiaoxin's leader needs to buy after mod  1,000,000,007 .
 

Sample Input
  
  
3 aa aabb a
 

Sample Output
  
  
1 2 1
 

Source
 

Recommend
wange2014


有点类似于组合,用杨辉三角与二项式系数的关系打出一个表。


#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int c[1005][1005];
int main()
{
    int cnt[1005],ch[1005],T;
    char S[1005];
    c[0][0]=1;
    c[1][0]=c[1][1]=1;
    for(int i=2;i<1005;i++) {
        c[i][0]=c[i][i]=1;
        for(int j=1;j<i;j++) {
            c[i][j]=c[i-1][j-1]+c[i-1][j];
            if(c[i][j]>=1000000007) {
                c[i][j]%=1000000007;
            }
        }
    }
    scanf("%d",&T);
    while(T--) {
        scanf("%s",S);
        memset(cnt,0,sizeof(cnt));
        int k=0,flag=0,sum=0;
        long long ans=1;
        for(int i=0;i<strlen(S);i++) {
            if(!cnt[S[i]]) {
                ch[k++]=S[i];
            }
            cnt[S[i]]++;
        }
        for(int i=0;i<k;i++) {
            if(cnt[ch[i]]%2==1) {
                sum+=cnt[ch[i]]/2;
                flag++;
            }
            else {
                sum+=cnt[ch[i]]/2;
            }
            cnt[ch[i]]/=2;
        }
        if(flag>1) {
            printf("0\n");
            continue;
        }
        for(int i=0;i<k;i++) {
            if(cnt[ch[i]]==0) {
                continue;
            }
            else {
                ans*=c[sum][cnt[ch[i]]];
                sum-=cnt[ch[i]];
                if(ans>1000000007) {
                    ans%=1000000007;
                }
            }
        }
        printf("%I64d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值