HDU1007 Quoit Design 分治

Quoit Design

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 43318    Accepted Submission(s): 11252


Problem Description
Have you ever played quoit in a playground? Quoit is a game in which flat rings are pitched at some toys, with all the toys encircled awarded.
In the field of Cyberground, the position of each toy is fixed, and the ring is carefully designed so it can only encircle one toy at a time. On the other hand, to make the game look more attractive, the ring is designed to have the largest radius. Given a configuration of the field, you are supposed to find the radius of such a ring.

Assume that all the toys are points on a plane. A point is encircled by the ring if the distance between the point and the center of the ring is strictly less than the radius of the ring. If two toys are placed at the same point, the radius of the ring is considered to be 0.
 

Input
The input consists of several test cases. For each case, the first line contains an integer N (2 <= N <= 100,000), the total number of toys in the field. Then N lines follow, each contains a pair of (x, y) which are the coordinates of a toy. The input is terminated by N = 0.
 

Output
For each test case, print in one line the radius of the ring required by the Cyberground manager, accurate up to 2 decimal places. 
 

Sample Input
  
  
2 0 0 1 1 2 1 1 1 1 3 -1.5 0 0 0 0 1.5 0
 

Sample Output
  
  
0.71 0.00 0.75
 

 题目大意:求所给点中最近的2个点的距离的一半,但是由于点的数量比较多,所以枚举显然是会超时的,需要分治。

由于HDOJ的G++是MINGWC++是MS-VC++所以G++交的时候居然TLE了。。。看来以后HDOJ的大数据题还是得用C++提交。

AC代码:

//************************************************************************//
//*Author : Handsome How                                                 *//
//************************************************************************//
//#pragma comment(linker, "/STA    CK:1024000000,1024000000")
#pragma warning(disable:4996) 
#include <vector>
#include <map>
#include <set>
#include <deque>
#include <queue>
#include <stack>
#include <algorithm>
#include <sstream>
#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <cstring>
#include <ctime>                                                
#include <cassert>
#if defined(_MSC_VER) || __cplusplus > 199711L
#define aut(r,v) auto r = (v)
#else
#define aut(r,v) __typeof(v) r = (v)
#endif
#define each(it,o) for(aut(it, (o).begin()); it != (o).end(); ++ it)
#define fur(i,a,b) for(int i=(a);i<=(b);i++)
#define furr(i,a,b) for(int i=(a);i>=(b);i--)
#define cl(a) memset((a),0,sizeof(a))
using namespace std;
typedef long long LL;
//----------------------------------------------------
struct Point
{
    double x;
    double y;
}point[100005],py[100005];
double getdis(Point A, Point B) {
    return sqrt((A.x - B.x)*(A.x - B.x) + (A.y - B.y)*(A.y - B.y));
}
bool cmpx(Point A, Point B) {
    return A.x < B.x;
}
bool cmpy(Point A, Point B) {
    return A.y < B.y;
}
double solve(int l,int r) {
    if (l + 1 == r)return getdis(point[l], point[r]);     //two points only
    if (l + 2 == r) {
        double tmp1,tmp2,tmp3;
        tmp1 = getdis(point[l], point[l + 1]);
        tmp2 = getdis(point[l], point[r]);
        tmp3 = getdis(point[l + 1], point[r]);
        if (tmp1 <= tmp2&&tmp1 <= tmp3)return tmp1;
        if (tmp2 <= tmp1&&tmp2 <= tmp3)return tmp2;
        return tmp3;
    }                                                    //three points only 
    int mid = (l + r )>>1;
    double mini = min(solve(l,mid),solve(mid+1,r));
    double tmp;
    int midx=point[mid].x,t=0;
    furr(i, mid, l) {
        if (point[i].x <= midx - mini) break;   //if it's too far away 
        py[t].x = point[i].x;					//it's not necessary to check the point	
        py[t].y = point[i].y;					//else put them in a new set
        t++;
    }
    fur(i, mid + 1, r) {
        if (point[i].x >= midx + mini) break;		
        py[t].x = point[i].x;						
        py[t].y = point[i].y;
        t++;
    }
    sort(py, py+t, cmpy);							//sort them in the value of Y
    fur(i, 0, t-1)fur(j, i + 1, t-1) {
        if (point[j].y-point[i].y > mini)break;		//so we can break when point[j].y-point[i].y > mini
        tmp = getdis(py[i],py[j]);
        if (tmp < mini)mini = tmp;
    }
    return mini;
}
int main()
{
    //freopen("E:\\data.in", "r", stdin);
    int cnt;
    while (scanf("%d", &cnt) != EOF)
    {
        if (cnt==0)break;
        double ans;
        fur(i, 1, cnt)scanf("%lf%lf", &point[i].x, &point[i].y);
        sort(point + 1, point + 1 + cnt, cmpx);
        ans = solve(1,cnt);
        printf("%.2lf\n",ans/2);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值