大数类BigInteger,高精度类BigDecimal

这个博客,我只想单纯地说明java,BigInteger和BigDecimal的强大

C++的快速幂取模,在java中可以用BigInteger封装的方法来代替。

BigDecimal实现了高精度的算法,是一个非常强大的类,在java API可以查具体强大的用法,因为用法太多了,在这里就不具体写了

 

 先写一下BigInteger的一个例子

Gdufe_2018_Summer II (B)

Given a positive integer N, you should output the most right digit of N^N.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).

Output

For each test case, you should output the rightmost digit of N^N.

Sample Input

2
3
4

Sample Output

7
6
  

Hint

In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
 

 

题解:先输入T为测试样例的个数,然后输入N,求N^N的个位数

看似下面的代码很暴力,不过BigInteger a =  modPow(BigInteger b,BigInteger mod); 这个方法实现了位算法,速度也很快。

 

import java.math.BigInteger;
import java.util.Scanner;
 
public class Main {
    static Scanner scan = new Scanner(System.in);
    public static void main(String[] args) {
        // TODO Auto-generated method stub
    	int t =scan.nextInt();
        for(int i=0;i<t;i++){
            BigInteger x = scan.nextBigInteger();
            pow3(x,x);

        }
        scan.close();
    }
    static void pow3(BigInteger x,BigInteger y){
        BigInteger mod = new BigInteger("10");
        BigInteger s = x.modPow(y,mod);
        System.out.println(s);     
    }
}

 

BigDecimal的一个例子

HDU - 1063

Given a positive integer N, you should output the most right digit of N^N.

Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems.

This problem requires that you write a program to compute the exact value of R n where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.

Input

The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.

Output

The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.

Sample Input

95.123 12
0.4321 20
5.1234 15
6.7592  9
98.999 10
1.0100 12

Sample Output

548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201

题解:求一个小数的次方,BigDecimal大数double类,配合上String类,简直骚无敌。

BigDecimal a = scan.nextBigDecimal();  //大数类的double;

String ans = a.stripTrailingZeros().toPlainString();  //去掉尾部零,转换成非科学计数法字符串 

ans=ans.substring(1);  //返回以位置1开头的该字符串

import java.util.*;
import java.math.*;
 
public class Main {
 
	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner scan = new Scanner(System.in);
		while(scan.hasNext()){
			BigDecimal a = scan.nextBigDecimal();  //大数类的double;
			int b = scan.nextInt();
			a = a.pow(b);
			String ans = a.stripTrailingZeros().toPlainString();  //去掉尾部零,转换成非科学计数法字符串  
			if(ans.charAt(0)=='0'){  //如果以0开头  
				ans=ans.substring(1);  //返回以位置1开头的该字符串  
			}
			System.out.println(ans);			
		} 
	} 
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值