迷宫问题

迷宫问题
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Description

定义一个二维数组: 
int maze[5][5] = {

	0, 1, 0, 0, 0,

	0, 1, 0, 1, 0,

	0, 0, 0, 0, 0,

	0, 1, 1, 1, 0,

	0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output

左上角到右下角的最短路径,格式如样例所示。

Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)

(4, 4)

依然利用广搜进行解决,注意对路径的存储,用到了栈,要建立一个存储路径的数组,注意两个地方,就是father数组的初始化,以及压栈的条件

#include<iostream>
#include<cmath>
#include<algorithm>
#include<stack>
#include<cstring>
#include<queue>
using namespace std;

int maze[5][5];
struct node {
    int x, y;
};

stack<node> way;
int d[4][2] = {{0, -1}, {-1, 0}, {0, 1}, {1, 0}};
queue<node> road;
int book[5][5];
node father[5][5];

int bfs()
{
    memset(book, 0, sizeof(book));
    while(!road.empty())
        road.pop();
    
    node now, next;
    now.x = 0;
    now.y = 0;
    father[0][0] = now;
    road.push(now);
    book[0][0] = 1;
    while(!road.empty()) {
        now = road.front();
        road.pop();
        int i;
        for(i=0; i<4; ++i) {
            next.x = now.x + d[i][0];
            next.y = now.y + d[i][1];
            
            if(next.x < 0 || next.x >=5 || next.y < 0 || next.y >=5 || book[next.x][next.y] || maze[next.x][next.y] == 1)
                continue;
            father[next.x][next.y] = now;
            book[next.x][next.y] = 1;
            road.push(next);
            if(next.x == 4 && next.y ==4) {
                return 1;
            }
        }
    }
    return 0;
}

int main()
{
    int i, j;
    for(i=0; i<5; ++i) {
        for(j=0; j<5; ++j) {
            scanf("%d", &maze[i][j]);
            father[i][j].x = i;
            father[i][j].y = j;
        }
    }
    
    bfs();
    node temp;
    temp.x = 4, temp.y = 4;
    while(temp.x!=0 || temp.y!=0) {
        way.push(temp);
        temp = father[temp.x][temp.y];
    }
    printf("(0, 0)\n");
    while(!way.empty())
    {
        printf("(%d, %d)\n", way.top().x, way.top().y);
        way.pop();
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值