Poj 2104 K-th Number 主席树 解题报告

Description

You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in the array segment.
That is, given an array a[1…n] of different integer numbers, your program must answer a series of questions Q(i, j, k) in the form: “What would be the k-th number in a[i…j] segment, if this segment was sorted?”
For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the question be Q(2, 5, 3). The segment a[2…5] is (5, 2, 6, 3). If we sort this segment, we get (2, 3, 5, 6), the third number is 5, and therefore the answer to the question is 5.

Input

The first line of the input file contains n — the size of the array, and m — the number of questions to answer (1 <= n <= 100 000, 1 <= m <= 5 000).
The second line contains n different integer numbers not exceeding 109 by their absolute values — the array for which the answers should be given.
The following m lines contain question descriptions, each description consists of three numbers: i, j, and k (1 <= i <= j <= n, 1 <= k <= j - i + 1) and represents the question Q(i, j, k).

Output

For each question output the answer to it — the k-th number in sorted a[i…j] segment.

Sample Input

7 3
1 5 2 6 3 7 4
2 5 3
4 4 1
1 7 3

Sample Output

5
6
3

思路

建n+1棵线段树,每颗线段数结构都是一样,先建一棵空树,然
后每棵树都在前一棵树的基础上进行修改。这里要注意,输入用scanf,不然用cin会超时

代码

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<vector>
using namespace std;
const int N=1e5+5;
struct Tree        ///树的节点
{
    int l,r,ls,rs;
    int sum;
};
Tree tree[N*20];
int a[N],b[N],s[N],num=0,n,m;
void build(int l,int r,int &node)   ///建空树,和线段树差不多
{
    node=++num;
    tree[node].l=l;
    tree[node].r=r;
    tree[node].sum=0;
    if (l==r) return ;
    int m=(l+r)/2;
    build(l,m,tree[node].ls);
    build(m+1,r,tree[node].rs);
}
void insert(int n1,int &n2,int pos)  ///在上一棵树的基础上建立新树
{
    n2=++num;
    tree[n2].l=tree[n1].l;     ///区间和上一棵树一样
    tree[n2].r=tree[n1].r;
    tree[n2].rs=tree[n1].rs;   ///保证没有修改的部分和上一棵树一样
    tree[n2].ls=tree[n1].ls;
    tree[n2].sum=tree[n1].sum+1;
    if (tree[n1].l==tree[n1].r) return ;
    int m=(tree[n1].l+tree[n1].r)/2;
    if (pos<=m) insert(tree[n1].ls,tree[n2].ls,pos);
    else insert(tree[n1].rs,tree[n2].rs,pos);
}
int query(int n1,int n2,int k)    ///查询的k小的树
{
    if (tree[n1].l==tree[n1].r) return b[tree[n1].l];
    int cut=tree[tree[n2].ls].sum-tree[tree[n1].ls].sum;
    if (cut>=k) return query(tree[n1].ls,tree[n2].ls,k);
    return query(tree[n1].rs,tree[n2].rs,k-cut);
}
int main()
{
    scanf("%d%d",&n,&m);
    for (int i=1;i<=n;i++)
    {
        scanf("%d",&a[i]);
        b[i]=a[i];
    }
    sort(b+1,n+b+1);
    build(1,n,s[0]);
    for (int i=1;i<=n;i++)
    {
        int pos=lower_bound(b+1,b+n+1,a[i])-b; ///找的a[i]要放的位置
        insert(s[i-1],s[i],pos);
    }
    while (m--)
    {
        int l,r,k;
        scanf("%d%d%d",&l,&r,&k);
        printf("%d\n",query(s[l-1],s[r],k));
    }
}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值