hdu 2586 How far away? LCA 解题报告

Problem Description

There are n houses in the village and some bidirectional roads connecting them. Every day peole always like to ask like this “How far is it if I want to go from house A to house B”? Usually it hard to answer. But luckily int this village the answer is always unique, since the roads are built in the way that there is a unique simple path(“simple” means you can’t visit a place twice) between every two houses. Yout task is to answer all these curious people.

Input

First line is a single integer T(T<=10), indicating the number of test cases.
For each test case,in the first line there are two numbers n(2<=n<=40000) and m (1<=m<=200),the number of houses and the number of queries. The following n-1 lines each consisting three numbers i,j,k, separated bu a single space, meaning that there is a road connecting house i and house j,with length k(0

Output

For each test case,output m lines. Each line represents the answer of the query. Output a bland line after each test case.

Sample Input

2
3 2
1 2 10
3 1 15
1 2
2 3

2 2
1 2 100
1 2
2 1

Sample Output

10
25
100
100

思路

裸的。
目的是提醒自己开双向边

代码

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
#include<stack>
using namespace std;
const int N=50000+5;
const int P=17+2;
int n,m,T,num,head[N],dis[N],father[N],deep[N],anc[N][P],flag[N];
struct edge
{
    int u,v,w;
    int next;
}ed[3*N];
void build(int u,int v,int w)
{
    ed[++num].u=u;
    ed[num].v=v;
    ed[num].w=w;
    ed[num].next=head[u];
    head[u]=num;
}
void dfs(int u)
{
    anc[u][0]=father[u];
    for (int i=1;i<=17;i++)
    anc[u][i]=anc[anc[u][i-1]][i-1];
    for (int i=head[u];i!=-1;i=ed[i].next)
    {
        int v=ed[i].v;
        if (flag[v]==0)
        {
            flag[v]=1;
            deep[v]=deep[u]+1;
            dis[v]=dis[u]+ed[i].w;
            father[v]=u;
            dfs(v);
        }
    }
}
int LCA(int x,int y)
{
    int a=x,b=y;
    if (deep[x]<deep[y]) {swap(x,y);swap(a,b);}
    for (int i=17;i>=0;i--)
    if (deep[y]<=deep[anc[x][i]]) x=anc[x][i];
    if (x==y) return dis[a]-dis[x];
    for (int i=17;i>=0;i--)
    if (anc[x][i]!=anc[y][i]) {x=anc[x][i];y=anc[y][i];}
    return dis[a]+dis[b]-2*dis[anc[x][0]];
}
void clear()
{
    num=0;
    memset(head,-1,sizeof(head));
    memset(anc,-1,sizeof(anc));
    memset(deep,0,sizeof(deep));
    memset(dis,0,sizeof(dis));
    memset(flag,0,sizeof(flag));
    memset(father,0,sizeof(father));
}
int main()
{
    scanf("%d",&T);
    while(T--)
    {
        clear();
        scanf("%d%d",&n,&m);
        for (int i=1;i<n;i++)
        {
            int u,v,w;
            scanf("%d%d%d",&u,&v,&w);
            build(u,v,w);
            build(v,u,w);
        }
        flag[1]=1;
        dfs(1);
        for (int i=1;i<=m;i++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            printf("%d\n",LCA(x,y));
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值