hdu 3367 Pseudoforest 变形最大生成树 解题报告

Problem Description

In graph theory, a pseudoforest is an undirected graph in which every connected component has at most one cycle. The maximal pseudoforests of G are the pseudoforest subgraphs of G that are not contained within any larger pseudoforest of G. A pesudoforest is larger than another if and only if the total value of the edges is greater than another one’s.

Input

The input consists of multiple test cases. The first line of each test case contains two integers, n(0 < n <= 10000), m(0 <= m <= 100000), which are the number of the vertexes and the number of the edges. The next m lines, each line consists of three integers, u, v, c, which means there is an edge with value c (0 < c <= 10000) between u and v. You can assume that there are no loop and no multiple edges.
The last test case is followed by a line containing two zeros, which means the end of the input.

Output

Output the sum of the value of the edges of the maximum pesudoforest.

Sample Input

3 3
0 1 1
1 2 1
2 0 1
4 5
0 1 1
1 2 1
2 3 1
3 0 1
0 2 2
0 0

Sample Output

3
5

题意:

每一个联通子集顶多只能有一个环,在给定边里求满足条件的最大总长度

思路:

和最大生成树很像。。不过这题是可以分成多个联通子集的,注意处理下最多只能有一个环就可以了
两个联通子集,都有环的时候肯定不能连接了, 不然新的联通子集就有两个环了。
其中一个有环的时候可以连接,注意标记新的联通子集有环
都没环的时候当然可以连接,且新的联通子集无环。

代码

#include<iostream>  
#include<cstdio>  
#include<cstring>  
#include<algorithm>  
#include<cmath>  
using namespace std;  
const int N=10000+5;
const int M=100000+5;
int n,m,father[N],flag[N];  
struct Edge  
{  
    int u,v,w;  
}ed[M];  
bool cmp(Edge a,Edge b)  
{  
    return a.w>b.w;  
}  
int getfather(int x)  
{  
    int r=x,j;  
    while(r!=father[r])  
    r=father[r];  
    while(x!=father[x])  
    {j=x;x=father[x];father[j]=r;}  
    return r;  
}  
int kruskal()  
{  
    int ans=0,x,y;  
    for (int i=0;i<m;i++)  
    {  
        x=getfather(ed[i].u);  
        y=getfather(ed[i].v);  
        if (x==y)  
        {  
            if (!flag[x]) {flag[x]=1;ans+=ed[i].w;}  
            continue;  
        }  
        if (flag[x]&&flag[y]) continue;  
        father[x]=y;  
        ans+=ed[i].w;  
        if (!flag[x]&&!flag[y]) continue;  
        flag[x]=flag[y]=1;  
    }  
    return ans;  
}  
int main()  
{  
    int u,v,w;  
    while(scanf("%d %d",&n,&m)&&n)  
    {  
        for (int i=0;i<=n;i++)  
        father[i]=i;  
        memset(flag,0,sizeof(flag));  
        for (int i=0;i<m;i++)  
        scanf("%d %d %d",&ed[i].u,&ed[i].v,&ed[i].w);  
        sort(ed,ed+m,cmp);  
        printf("%d\n",kruskal());  
    }  
    return 0;  
}  
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值