hdu 1142 A Walk Through the Forest 最短路+记忆化搜索 解题报告

Problem Description

Jimmy experiences a lot of stress at work these days, especially since his accident made working difficult. To relax after a hard day, he likes to walk home. To make things even nicer, his office is on one side of a forest, and his house is on the other. A nice walk through the forest, seeing the birds and chipmunks is quite enjoyable.
The forest is beautiful, and Jimmy wants to take a different route everyday. He also wants to get home before dark, so he always takes a path to make progress towards his house. He considers taking a path from A to B to be progress if there exists a route from B to his home that is shorter than any possible route from A. Calculate how many different routes through the forest Jimmy might take.

Input

Input contains several test cases followed by a line containing 0. Jimmy has numbered each intersection or joining of paths starting with 1. His office is numbered 1, and his house is numbered 2. The first line of each test case gives the number of intersections N, 1 < N ≤ 1000, and the number of paths M. The following M lines each contain a pair of intersections a b and an integer distance 1 ≤ d ≤ 1000000 indicating a path of length d between intersection a and a different intersection b. Jimmy may walk a path any direction he chooses. There is at most one path between any pair of intersections.

Output

For each test case, output a single integer indicating the number of different routes through the forest. You may assume that this number does not exceed 2147483647

Sample Input

5 6
1 3 2
1 4 2
3 4 3
1 5 12
4 2 34
5 2 24
7 8
1 3 1
1 4 1
3 7 1
7 4 1
7 5 1
6 7 1
5 2 1
6 2 1
0

Sample Output

2
4

思路

题目意思就是让我们寻找一共有多少条符合题意的路。
能够从点A走到点B的要求是:点A到终点的最短路 > 点B到终点的最短路。 也就是说:从终点出发,求每一个点的最短路,然后那些最短路的值记录起来,作为能否通过的判断条件。
可以用记忆化搜索来搜索出一共多少条符合要求的路。(普通的dfs是超时的,bfs是超内存的)

代码

非常不清真,个人喜欢邻接表来存储边,但是听了ZJC的话用了vector。感觉还是可以,不过以后还是用在Tarjan缩点重新建边的过程里面吧。。

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<cmath>
#include<vector>
#include<queue>
using namespace std;  
const int INF=0x3f3f3f3f;  
const int N=1000+5;  
vector<int> road[N];
queue<int> q;
int n,t,sum,map[N][N],dis[N],s[N],flag[N];
void init()  
{  
    sum=0;  
    memset(s,0,sizeof(s)); 
    memset(map,INF,sizeof(map)); 
    for (int i=1;i<=n;i++)
    road[i].clear();
    for (int i=0;i<=n;i++)
    map[i][i]=0;
}
void SPFA() 
{   
    memset(flag,0,sizeof(flag));  
    memset(dis,INF,sizeof(dis));
    dis[2]=0;flag[2]=1;
    q.push(2);  
    while(!q.empty())  
    {  
        int u=q.front();  
        q.pop();  
        flag[u]=0;  
        for (int i=1;i<=n;i++)  
        {  
            if (dis[i]>dis[u]+map[u][i])  
            {
                dis[i]=dis[u]+map[u][i];  
                if (flag[i]==0)  
                {  
                    q.push(i);  
                    flag[i]=1;  
                }  
            }  
        }  
    }  
}  
int dfs(int now)    
{  
    if (now==2) return 1;
    if (s[now]) return s[now];
    for (int i=0;i<road[now].size();i++)  
    if (dis[now]>dis[road[now][i]]) s[now]+=dfs(road[now][i]);  
    return s[now]; 
}//记忆化搜索  
int main()  
{  
    while(true)  
    {  
        scanf("%d",&n);
        if (n==0) break;
        scanf("%d",&t);  
        init();  
        for (int i=1;i<=t;i++)
        {  
            int u,v,w;
            scanf("%d%d%d",&u,&v,&w);
            if (w<map[u][v])
            {
                map[u][v]=map[v][u]=w;
                road[u].push_back(v);
                road[v].push_back(u);
            }
        }  
        SPFA();  
        sum=dfs(1);
        printf("%d\n",sum);  
    }  
    return 0;  
}  
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值