hdu 4283 You Are the One 区间DP 解题报告

Problem Description

The TV shows such as You Are the One has been very popular. In order to meet the need of boys who are still single, TJUT hold the show itself. The show is hold in the Small hall, so it attract a lot of boys and girls. Now there are n boys enrolling in. At the beginning, the n boys stand in a row and go to the stage one by one. However, the director suddenly knows that very boy has a value of diaosi D, if the boy is k-th one go to the stage, the unhappiness of him will be (k-1)*D, because he has to wait for (k-1) people. Luckily, there is a dark room in the Small hall, so the director can put the boy into the dark room temporarily and let the boys behind his go to stage before him. For the dark room is very narrow, the boy who first get into dark room has to leave last. The director wants to change the order of boys by the dark room, so the summary of unhappiness will be least. Can you help him?

Input

  The first line contains a single integer T, the number of test cases. For each case, the first line is n (0 < n <= 100)
  The next n line are n integer D1-Dn means the value of diaosi of boys (0 <= Di <= 100)

Output

  For each test case, output the least summary of unhappiness .

Sample Input

2
  
5
1
2
3
4
5

5
5
4
3
2
2

Sample Output

Case #1: 20
Case #2: 24

思路

区间DP

由于要满足出栈的条件,所以只能进行微调。dp[x][y] 表示 区间 [x, y] 上所有的数出栈后的最小花费。那么对于区间 [x, y] 中的数字 a[x],有可能第1个出栈,也有可能最后一个出栈,如果第i个出栈的话前i-1个数字要按照顺序出栈,然后a[x]出栈,[i+1,y]出栈。对于a[x]要加上a[x]i的花费,对于[i+1, y]要加上sum(i+1, y) (i-x+2)的额外花费。

代码

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<vector>
using namespace std;
const int INF=0xfffffff;
const int N=110;
long long dp[N][N],val[N],pre[N];
int T,n;
int main ()
{
    scanf("%d",&T);
    for (int t=1;t<=T;t++)
    {
        scanf("%d",&n);
        val[0]=pre[0]=0;
        for (int i=1;i<=n;i++)
        {
            scanf("%I64d",&val[i]);
            pre[i]=pre[i-1]+val[i];
        }
        memset(dp,0,sizeof(dp));
        for (int l=1;l<n;l++)
        for (int i=1;i+l<=n;i++)
        {
            int j=i+l;
            long long minn=INF,num;
            for (int k=i;k<=j;k++)
            {
                num=val[i]*(k-i)+(pre[j]-pre[k])*(k-i+1)+dp[i+1][k]+dp[k+1][j];
                minn=min(minn,num);
            }
            dp[i][j]=minn;
        }
        printf ("Case #%d: %I64d\n",t,dp[1][n]);
    }
    return 0;
}
/*
2
  
5
1
2
3
4
5

5
5
4
3
2
2
*/
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值