PAT A1010 Radix(25)[进制,进制]

Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is yes, if 6 is a decimal number and 110 is a binary number.

Now for any pair of positive integers N 1 N_1 N1 and N 2 N_2 N2, your task is to find the radix of one number while that of the other is given.

Input Specification:

Each input file contains one test case. Each case occupies a line which contains 4 positive integers:

N1 N2 tag radix

Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set { 0-9, a-z } where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number radix is the radix of N1 if tag is 1, or of N2 if tag is 2.

Output Specification:

For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print Impossible. If the solution is not unique, output the smallest possible radix.

Sample Input 1:

6 110 1 10    

Sample Output 1:

2   

Sample Input 2:

1 ab 1 2    

Sample Output 2:

Impossible

题意

思路1

  1. 统一将 N 1 N_1 N1radix 进制数转换为十进制数 target (若不满足则交换)
  2. 二分查找满足条件的进制使得 k 进制数 N 2 N_{2} N2 的十进制为 target ,结果即为 k

代码1

#include <iostream>
#include <algorithm>
using namespace std;

typedef long long LL;

// 字符转进制 
int get(char c)
{
	if(c <= '9') return c - '0';  // 0-9
	return c - 'a' + 10;          // a-z	
} 

// 计算正整数 s 在 r 进制下的十进制数 
LL cal(string s, LL r)
{
	LL res = 0;
	for(const auto &c : s)
	{
	    if((double)res * r + get(c) > 1e16) return 1e18;
		res = res * r + get(c);
	}
	return res;
}
 
int main()
{
	string n1, n2;
	cin >> n1 >> n2;
	int tag, radix;
	cin >> tag >> radix;
	
	if(tag == 2)  swap(n1, n2);  // radix 指的是 n1
	LL target = cal(n1, radix); // 对应的十进制数
	
	
	// 二分查找
	LL l = 0, r = max(target, 36ll); // 最大可能进制
	for(auto c: n2) l = max(l, (LL)get(c) + 1);  // 最小可能进制
	
	while(l < r)
	{
		LL mid = l + r >> 1;
		if(cal(n2, mid) >= target)
			r = mid;
		else 
			l = mid + 1;	
	}
	if(target != cal(n2, l)) puts("Impossible");
	else printf("%lld\n", l);
	return 0;
 } 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值