Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.
Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:
4 1 6 3 5 7 2
题意
后序遍历和中序遍历,请你输出它的层序遍历。
思路1
建树
代码1
#include <iostream>
#include <queue>
#include <vector>
#include <unordered_map>
using namespace std;
const int N = 40;
int post[N], in[N]; // 后序遍历和中序遍历结果
unordered_map<int, int> pos; // 记录中序遍历某个值的下标
unordered_map<int, int> l, r; // 存储某个点左右子树情况
// 前面是子树中序遍历端点,后面是后续遍历两个端点
int build(int il, int ir, int pl, int pr)
{
// 当前子树根结点
int root = post[pr];
// 中序遍历中的分界点
int k = pos[root];
// 左子树存在
if(il < k) l[root] = build(il, k-1, pl, pl + (k-1-il));
// 右子树存在
if(k < ir) r[root] = build(k+1, ir, pl+(k-il), pr-1);
return root;
}
void bfs(int s)
{
vector<int> ans;
queue<int> q;
q.push(s);
while(!q.empty())
{
int now = q.front();
ans.push_back(now);
q.pop();
if(l.count(now)) q.push(l[now]);
if(r.count(now)) q.push(r[now]);
}
printf("%d", ans[0]);
for(int i = 1; i < ans.size(); i++)
printf(" %d", ans[i]);
}
int main()
{
int n;
scanf("%d", &n);
for(int i = 0; i < n; i++) scanf("%d", &post[i]);
for(int i = 0; i < n; i++)
{
scanf("%d", &in[i]);
pos[in[i]] = i; // 中序遍历中值为 in[i] 下标为 i
}
// 建树
int root = build(0, n-1, 0, n-1);
// 层序遍历
bfs(root);
return 0;
}