HDU 1010 Tempter of the Bone【dfs剪枝】

Tempter of the Bone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 133736    Accepted Submission(s): 35982


Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
 

Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter;
'S': the start point of the doggie;
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.
 

Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
 

Sample Input
  
  
4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0
 

Sample Output
  
  
NO YES
 

Author

ZHANG, Zheng


最开始没有看题以为是在T秒内到达,果断bfs开心的wa了;

要求:T秒准时到达;所以要用dfs

但是直接暴力会超时,所以要用到路径剪枝和奇偶剪枝;

路径剪枝: 对于已经超过时间的点直接return;

奇偶剪枝:

首先,从一个点到另一个点的最短路径是:int t = fabs(x - xx) + fabs(y - yy);

那么,如果要在T秒到达,(T - t)就应为偶数;

所以直接减掉相减等于奇数的点;

在看网上代码时,发现还有一种神奇的剪枝方式;

先记录X的数量为sum,如果n*m - sum - 1 < T;

说明能走的路不足T步,就可以直接减掉了;

本人的代码没有第三种剪枝也是过了,若果有兴趣的话可以自行尝试;



#include<bits/stdc++.h>
using namespace std;
int n, m, k, flag;
char maps[8][8];
int vis[8][8];
int Step[4][2] = {1, 0, 0, 1, -1, 0, 0, -1};
void dfs(int nx, int ny, int s)
{
    if(maps[nx][ny] == 'D' && s == k)
    {
        flag = 1;
        return;
    }
    if(s >= k)
        return;
    for(int i = 0; i < 4; i++)
    {
        int xx = nx + Step[i][0];
        int yy = ny + Step[i][1];
        if(xx >= 0 && xx <= n && yy >= 0 && yy <= m &&
           !vis[xx][yy] && maps[xx][yy] != 'X')
        {
            vis[xx][yy] = 1;
            dfs(xx, yy, s + 1);
            if(flag)
                return;
            vis[xx][yy] = 0;
        }
    }
}
int main()
{
    int xx, yy, x, y;
    while(cin >> n >> m >> k)
    {
        flag = 0;
        if(n == 0 && m == 0 && k == 0)
            break;
        for(int i = 0; i < n; i++)
        {
            cin >> maps[i];
            for(int j = 0; j < m; j++)
            {
                if(maps[i][j] == 'S')
                {
                    xx = i;
                    yy = j;
                }
                if(maps[i][j] == 'D')
                {
                    x = i;
                    y = j;
                }
            }
        }
        int t = fabs(x - xx) + fabs(y - yy);
        if(k < t)
            cout << "NO" << endl;
        else if((k - t) % 2)
            cout << "NO" << endl;
        else
        {
            n--;
            m--;
            memset(vis, 0, sizeof vis);
            vis[xx][yy] = 1;
            flag = 0;
            dfs(xx, yy, 0);
            if(flag)
                cout << "YES" << endl;
            else
                cout << "NO" << endl;
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值