1
利用指针编写程序,统计字符串的长度。(10分)
题目内容:利用指针编写程序,统计字符串的长度。(不要使用求字符串长度函数)
输入格式:
gets()
输出格式:
"Length of the string is %d\n"
输入样例:
I like programming.
输出样例:
Length of the string is 19
时间限制:500ms内存限制:32000kb
#include <stdio.h>
int main()
{
char str[50],*p=str;
int i=0;
gets(p);
for(i=0;*p!='\0';i++)
p++;
printf("Length of the string is %d\n",i);
return 0;
}
2
利用指针编程,将数组中所有元素的值对称交换。(10分)
题目内容:利用指针编程,将数组中所有元素的值对称交换。使用数组int a[10]
输入格式:
%d
输出格式:
%2d
输入样例: