Uva 10499 The Land of Justice

Problem H
The Land of Justice
Input:
standard input
Output: standard output
Time Limit: 4 seconds

In the Land of Justice the selling price of everything is fixed all over the country. Nobody can buy a thing and sell it in double price. But, that created problems for the businessmen. They left their business and went to the production. So, after some days everybody was in production and nobody in business. And the people didn’t get their necessary things though the country was self-sufficient in every sector.

 

The government became very much anxious. But, they were intelligent enough to call the mathematicians.

 

The mathematicians gave a solution.  They suggested setting the surface area of an object as its selling-unit instead of its volume. Actually the clever mathematicians were very much interested to establish their own business.

 

Now, the government asks the programmers to build the software that would calculate the profit things.

 

Here your job is to calculate the business profit for a solid sphere. A businessman buys a complete sphere and to maximize his profit he divides it inn equal parts. All cut should go through the axis of the sphere. And every part should look like the picture below:

 

Input

You are given a sequence of integers N (0 < N < 231), indicating the numbers of parts of the sphere. The input file is terminated with a negative number. This number should not be processed.

 

Output

Calculate the profit over the sold pieces. The result should be in percentage and rounded to the nearest integer.

  

Sample input

2

2

-1

 

Sample output

50%

50%



题目大意:

由于政府的政策导致商家的减少,而此时数学家提出意见说一件物品以它的表面积为销售单位而不是体积。这种方法被政府接受了,数学家为了盈利其实也想经商。


问题如下:

就是给你一个球,本来的表面积特定的,但为了得到利润,把它劈开相同的大小的块,此时表面积肯定会增加,而相对于原来增加了多少的百分比,这就需要你去计算的。


题目解析:

初始球的表面积 4*pi*r*r,n=2时;即切一刀多了2个圆面积 2*pi*r*r,利润为50%,n=3时;多三个圆面积,利润为75%,以此类推

当n等分时,多n个圆面面积。


ans=(n*pi*r*r)/(4*pi*r*r)*100%=n/4*100%


#include<stdio.h>
#include<math.h>

int main() {
	double n;
	while(scanf("%lf",&n) != EOF && n>=0) {
		if(n == 1)
			printf("0%\n");
		else
			printf("%.0lf%\n",n*25);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值