UVA 10878 Decode the tape

C - Decode the tape
Time Limit:3000MS    Memory Limit:0KB    64bit IO Format:%lld & %llu

Description

 

"Machines take me by surprise with great frequency."

Alan Turing

Your boss has just unearthed a roll of old computer tapes. The tapes have holes in them and might contain some sort of useful information. It falls to you to figure out what is written on them.

Input

The input will contain one tape.

Output

Output the message that is written on the tape.

Sample Input

___________
| o   .  o|
|  o  .   |
| ooo .  o|
| ooo .o o|
| oo o.  o|
| oo  . oo|
| oo o. oo|
|  o  .   |
| oo  . o |
| ooo . o |
| oo o.ooo|
| ooo .ooo|
| oo o.oo |
|  o  .   |
| oo  .oo |
| oo o.ooo|
| oooo.   |
|  o  .   |
| oo o. o |
| ooo .o o|
| oo o.o o|
| ooo .   |
| ooo . oo|
|  o  .   |
| oo o.ooo|
| ooo .oo |
| oo  .o o|
| ooo . o |
|  o  .   |
| ooo .o  |
| oo o.   |
| oo  .o o|
|  o  .   |
| oo o.o  |
| oo  .  o|
| oooo. o |
| oooo.  o|
|  o  .   |
| oo  .o  |
| oo o.ooo|
| oo  .ooo|
|  o o.oo |
|    o. o |
___________

Sample Output

A quick brown fox jumps over the lazy dog.


题目解析:

'A' = 64+0+0+0+0+0+1

' ' =   0+32+0+0+0+0+0

'q' = 64+32+16+0+0+0+1

'u' = 64+32+16+0+4+0+1

‘i’ = 64+32+0+8+0+0+1

从以上顺序可得出,密码是按照ASCII码


#include <stdio.h>  
#include <string.h>  
  
int c[] = { 0, 0, 64, 32, 16, 8, 0, 4, 2, 1, 0};  
  
int main() {  
    char str[15];  
    int sum,i;  
    gets(str);  
    while(gets(str) && str[0] != '_'){  
        sum = 0;  
        int len = strlen(str);  
        for(i = 2;i < len;i++){  
            if(str[i] == 'o'){  
                sum += c[i];  
            }  
        }  
        printf("%c",sum);  
    }  
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值