Uva 10879 Code Refactoring

Problem B
Code Refactoring
Time Limit: 2 seconds
"Harry, my dream is a code waiting to be
broken. Break the code, solve the crime."
Agent Cooper

Several algorithms in modern cryptography are based on the fact that factoring large numbers is difficult. Alicia and Bobby know this, so they have decided to design their own encryption scheme based on factoring. Their algorithm depends on a secret code, K, that Alicia sends to Bobby before sending him an encrypted message. After listening carefully to Alicia's description, Yvette says, "But if I can intercept K and factor it into two positive integers, A and B, I would break your encryption scheme! And the K values you use are at most 10,000,000. Hey, this is so easy; I can even factor it twice, into two different pairs of integers!"

Input
The first line of input gives the number of cases, N (at most 25000). N test cases follow. Each one contains the code, K, on a line by itself.

Output
For each test case, output one line containing "Case #x: K = A * B = C * D", where A, B, C and D are different positive integers larger than 1. A solution will always exist.

Sample InputSample Output
3
120
210
10000000
Case #1: 120 = 12 * 10 = 6 * 20
Case #2: 210 = 7 * 30 = 70 * 3
Case #3: 10000000 = 10 * 1000000 = 100 * 100000

题意:

找出一个数的两个不同的因子,直接暴力求解。


#include <stdio.h>

int main() {
	int t;
	int n;
	int cut;
	while(scanf("%d",&t) != EOF) {

		for(int j=1;j<=t;j++) {
			scanf("%d",&n);
			cut = 0;

			int ans1,ans2,ans3,ans4;

			for(int i=2 ;i<=1000000;i++) {
				if(n % i == 0) {
					cut++;
				if(cut == 1) {
					ans1 = i;
					ans2 = n/i;
				}
				else
					if(cut == 2) {
						ans3 = i;
						ans4 = n/i;
					}
					else
						break;
				}
			}
			printf("Case #%d: %d = %d * %d = %d * %d\n",j,n,ans1,ans2,ans3,ans4);
		}	
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值