FZU - 2107 Hua Rong Dao(回溯)

Time Limit: 1000MS   Memory Limit: 32768KB   64bit IO Format: %I64d & %I64u

Description

Cao Cao was hunted down by thousands of enemy soldiers when he escaped from Hua Rong Dao. Assuming Hua Rong Dao is a narrow aisle (one N*4 rectangle), while Cao Cao can be regarded as one 2*2 grid. Cross general can be regarded as one 1*2 grid.Vertical general can be regarded as one 2*1 grid. Soldiers can be regarded as one 1*1 grid. Now Hua Rong Dao is full of people, no grid is empty.

There is only one Cao Cao. The number of Cross general, vertical general, and soldier is not fixed. How many ways can all the people stand?

Input

There is a single integer T (T≤4) in the first line of the test data indicating that there are T test cases.

Then for each case, only one integer N (1≤N≤4) in a single line indicates the length of Hua Rong Dao.

Output

For each test case, print the number of ways all the people can stand in a single line.

Sample Input

2
1
2

Sample Output

0
18

Hint

Here are 2 possible ways for the Hua Rong Dao 2*4.

题目大意:

给你一个4*n 的棋盘,上门放有只有1个2*2的曹操,和任意个1*2的将军、或者1*1的小兵,能组成多少种可能。


解析:这是一道回溯问题,要抓住几个关键条件只有1个曹操,所以递归的结束条件为曹操标记为真,和棋盘上格子全满。

还有一个关键点是下一层递归时,如果c == 4 的话,需要转到下一行的第一个进行判断。


#include <stdio.h>  
#include <string.h>  
const int N = 4;  

int cnt;  
bool king;  
bool vis[N][N];  
int n;  

void dfs(int r,int c,int sum) {  
	if( sum == 4*n && king ) {  
		cnt++;
		return ;  
	}
	if(c == 4) {
		dfs(r+1,0,sum);
		return ;
	}
	for(int i = r; i < n; i++) {
		for(int j = c; j < 4; j++) {  
			//2*2  
			if( !vis[i][j] && !vis[i+1][j] && !vis[i][j+1] && !vis[i+1][j+1] && !king && i+1 < n && j+1 < 4) {  
				vis[i][j] = vis[i+1][j] = vis[i][j+1] = vis[i+1][j+1] = true;  
				king = true;  
				dfs(i,j+1, sum+4);  
				vis[i][j] = vis[i+1][j] = vis[i][j+1] = vis[i+1][j+1] = false;  
				king = false;  
			}  
			//1*2  
			if( !vis[i][j] && !vis[i][j+1] && j+1 < 4) {  
				vis[i][j] = vis[i][j+1] = true;  
				dfs(i,j+1, sum+2);  
				vis[i][j] = vis[i][j+1] = false;  
			}  
			//2*1  
			if( !vis[i+1][j] && !vis[i][j] && i+1 < n) {  
				vis[i+1][j] = vis[i][j] = true;  
				dfs(i,j+1, sum+2);  
				vis[i+1][j] = vis[i][j] = false;  
			}  
			//1*1  
			if( !vis[i][j]) {  
				vis[i][j] = true;  
				dfs(i,j+1, sum+1);  
				vis[i][j] = false;  
			}  
			if( j == 3) {  
				c = 0;
			}  
		}  
	}  
}  

int main() {  
	int t;  
	while( scanf("%d",&t) != EOF) {  
		while( t-- ) {  
			memset(vis,0,sizeof(vis));  
			king = false;  
			cnt = 0;  
			scanf("%d",&n);  
			dfs(0,0,0);  
			printf("%d\n",cnt);  
		}  
	}  
	return 0;  
} 


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值