UVA - 167 The Sultan's Successors(回溯 八皇后问题改编)


 The Sultan's Successors 

The Sultan of Nubia has no children, so she has decided that the country will be split into up to k separate parts on her death and each part will be inherited by whoever performs best at some test. It is possible for any individual to inherit more than one or indeed all of the portions. To ensure that only highly intelligent people eventually become her successors, the Sultan has devised an ingenious test. In a large hall filled with the splash of fountains and the delicate scent of incense have been placed k chessboards. Each chessboard has numbers in the range 1 to 99 written on each square and is supplied with 8 jewelled chess queens. The task facing each potential successor is to place the 8 queens on the chess board in such a way that no queen threatens another one, and so that the numbers on the squares thus selected sum to a number at least as high as one already chosen by the Sultan. (For those unfamiliar with the rules of chess, this implies that each row and column of the board contains exactly one queen, and each diagonal contains no more than one.)

Write a program that will read in the number and details of the chessboards and determine the highest scores possible for each board under these conditions. (You know that the Sultan is both a good chess player and a good mathematician and you suspect that her score is the best attainable.)

Input

Input will consist of k (the number of boards), on a line by itself, followed by k sets of 64 numbers, each set consisting of eight lines of eight numbers. Each number will be a positive integer less than 100. There will never be more than 20 boards.

Output

Output will consist of k numbers consisting of your k scores, each score on a line by itself and right justified in a field 5 characters wide.

Sample input

1
 1  2  3  4  5  6  7  8
 9 10 11 12 13 14 15 16
17 18 19 20 21 22 23 24
25 26 27 28 29 30 31 32
33 34 35 36 37 38 39 40
41 42 43 44 45 46 47 48
48 50 51 52 53 54 55 56
57 58 59 60 61 62 63 64

Sample output

  260


题目大意:
八皇后问题的变形,这道题不是要我们求有多少种方法,而是在给定价值的棋盘格子放皇后,使得皇后放置的位置的总价值最大。


解析:参考了白书的126页的代码,用vis数组表示已经放置的皇后占据了哪些列以及哪些主、副对角线。
然后将放置皇后,改成加上该格子的值。


注意:不能忘了将vis初始化false和最后的输出的%5d。


#include <stdio.h>
#include <string.h>
#include <algorithm>

using namespace std;

const int N = 8;
const int INF = 0x3f3f3f3f;

int C[N];
int grid[N][N];
bool vis[3][N*3];
int Max;

void dfs(int cur) {
	if(cur == N) {
		int sum = 0;
		for(int i = 0; i < N; i++) {
			sum += grid[C[i]][i];
		}
		Max = max(Max,sum);
	}
	else {
		for(int i = 0; i < N; i++) {
			if(!vis[0][i] && !vis[1][cur+i] && !vis[2][cur-i+N]) {
				C[cur] = i;
				vis[0][i] = vis[1][cur+i] = vis[2][cur-i+N] = true;
				dfs(cur+1);
				vis[0][i] = vis[1][cur+i] = vis[2][cur-i+N] = false;
			}
		}
	}
}

int main() {
	int t;
	while( scanf("%d",&t) != EOF) {
		while( t--) {
			memset(vis,0,sizeof(vis));
			memset(C,0,sizeof(C));
			for(int i = 0; i < N; i++) {
				for(int j = 0; j < N; j++) {
					scanf("%d",&grid[i][j]);
				}
			}
			Max = -INF;
			dfs(0);
			printf("%5d\n",Max);
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值