UVA - 10300 Ecological Premium(水题)

Problem A

Ecological Premium

Input: standard input

Output: standard output

Time Limit: 1 second

Memory Limit: 32 MB

German farmers are given a premium depending on the conditions at their farmyard. Imagine the following simplified regulation: you know the size of each farmer's farmyard in square meters and the number of animals living at it. We won't make a difference between different animals, although this is far from reality. Moreover you have information about the degree the farmer uses environment-friendly equipment and practices, expressed in a single integer greater than zero. The amount of money a farmer receives can be calculated from these parameters as follows. First you need the space a single animal occupies at an average. This value (in square meters) is then multiplied by the parameter that stands for the farmer's environment-friendliness, resulting in the premium a farmer is paid per animal he owns. To compute the final premium of a farmer just multiply this premium per animal with the number of animals the farmer owns.

Input

The first line of input contains a single positive integer n (<20), the number of test cases. Each test case starts with a line containing a single integerf (0<f<20), the number of farmers in the test case. This line is followed by one line per farmer containing three positive integers each: the size of the farmyard in square meters, the number of animals he owns and the integer value that expresses the farmers environment-friendliness. Input is terminated by end of file. No integer in the input is greater than 100000 or less than 0.

 

Output

For each test case output one line containing a single integer that holds the summed burden for Germany's budget, which will always be a whole number. Do not output any blank lines.

 

Sample Input

3 
5 
1 1 1 
2 2 2 
3 3 3 
2 3 4 
8 9 2 
3 
9 1 8 
6 12 1 
8 1 1 
3 
10 30 40 
9 8 5 
100 1000 70 

Sample Output

38

86

7445


题意:
第一行输入一个测试用例的数量m,第二行输入农夫测试用例的数量n,
接着是n行数据的输入,每行3个数据,
分别是农夫拥有的土地面积、农夫拥有的动物的数量、生态系数。
要求你计算出农夫应获得的奖金。

计算公式:
奖金 = ∑((土地面积/动物数量)×生态系数×动物数量) = ∑(土地面积×生态系统数)

#include <stdio.h>

int main() {
	int m,n;
	int a,b,c,sum;
	while(scanf("%d",&m) != EOF) {
		while(m--) {
			scanf("%d",&n);
			sum = 0;
			for(int i = 0; i < n; i++) {
				scanf("%d%d%d",&a,&b,&c);
				sum += a*c;
			}
			printf("%d\n",sum);
		}
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值