UVA - 529 Addition Chains(迭代+dfs)


  Addition Chains 

An addition chain for n is an integer sequence $<a_0, a_1, a_2, \dots, a_m>$ with the following four properties:

  • a0 = 1
  • am = n
  • a0<a1<a2<...<am-1<am
  • For each k ( $1 \le k \le m$) there exist two (not neccessarily different) integers i and j ( $0 \le i, j \le k-1$) with ak =ai +aj

You are given an integer n. Your job is to construct an addition chain for n with minimal length. If there is more than one such sequence, any one is acceptable.

For example, <1,2,3,5> and <1,2,4,5> are both valid solutions when you are asked for an addition chain for 5.

Input Specification 

The input file will contain one or more test cases. Each test case consists of one line containing one integer  n (  $1 \le n \le 10000$). Input is terminated by a value of zero (0) for  n.

Output Specification 

For each test case, print one line containing the required integer sequence. Separate the numbers by one blank.


Hint: The problem is a little time-critical, so use proper break conditions where necessary to reduce the search space.

Sample Input 

5
7
12
15
77
0

Sample Output 

1 2 4 5
1 2 4 6 7
1 2 4 8 12
1 2 4 5 10 15
1 2 4 8 9 17 34 68 77



题目大意:
给定一个数,按要求输出元素最少的序列。

  1. a0 = 1 
  2. am = n 
  3. a0 < a1 < a2 < ... < am-1 < am 
  4. 对于任意的1<=k<=m,都有ak = ai + aj
解题思路:
a[k] = a[k-1] + a[i]  0 <= i <= k-1
迭代加深搜索。限定搜索的深度k,然后开始进行DFS搜索,如果搜索完没有解,深度deep++,继续上诉搜索,直到找到可行解。

#include <stdio.h>
#include <string.h>
const int N = 100;
int deep;
int ans[N];
int n;
bool ok;
void dfs(int cur) {
	if(cur == deep) {
		if(ans[cur] == n) {
			ok = true;
		}
		return;
	}
	for(int i = 0; i <= cur; i++) {
		if(ans[cur] + ans[i] <= n) { //剪枝1
			int sum = ans[i] + ans[cur];

			for(int k = cur+1; k < deep; k++) { //剪枝2
				sum *= 2;
			}
			if(sum < n) { //如果当前最大的策略都小于n,则跳过
				continue;
			}
			
			ans[cur+1] = ans[i] + ans[cur];
			dfs(cur+1);
			if(ok) {
				return;
			}
		}
	}
}
int main() {
	while(scanf("%d",&n) != EOF && n) {
		memset(ans,0,sizeof(ans));
		ans[0] = 1;
		ok = false;
		
		//求出最短深度
		int sum = 1;
		deep = 0;
		while(sum < n) {
			sum *= 2;
			deep++;
		}
		//迭代
		while(true) {
			dfs(0);
			if(ok) {
				break;
			}
			deep++;
		}
		for(int i = 0; i < deep; i++) {
			printf("%d ",ans[i]);
		}
		printf("%d\n",ans[deep]);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值