UVA - 299 Train Swapping(水题)

这篇博客介绍了一个古老火车站中'火车调换员'的任务,即重新排列火车车厢以优化顺序。随着这类员工的减少,铁路公司希望自动化这个过程,并要求创建一个算法来确定最少的相邻车厢交换次数,以正确排序火车。输入规格说明了测试用例的数量,每组测试用例包含火车长度和当前车厢顺序。输出应显示最小的交换次数。
摘要由CSDN通过智能技术生成


 Train Swapping 

At an old railway station, you may still encounter one of the last remaining ``train swappers''. A train swapper is an employee of the railroad, whose sole job it is to rearrange the carriages of trains.

Once the carriages are arranged in the optimal order, all the train driver has to do, is drop the carriages off, one by one, at the stations for which the load is meant.

The title ``train swapper'' stems from the first person who performed this task, at a station close to a railway bridge. Instead of opening up vertically, the bridge rotated around a pillar in the center of the river. After rotating the bridge 90 degrees, boats could pass left or right.

The first train swapper had discovered that the bridge could be operated with at most two carriages on it. By rotating the bridge 180 degrees, the carriages switched place, allowing him to rearrange the carriages (as a side effect, the carriages then faced the opposite direction, but train carriages can move either way, so who cares).

Now that almost all train swappers have died out, the railway company would like to automate their operation. Part of the program to be developed, is a routine which decides for a given train the least number of swaps of two adjacent carriages necessary to order the train. Your assignment is to create that routine.

Input Specification

The input contains on the first line the number of test cases (N). Each test case consists of two input lines. The first line of a test case contains an integer L, determining the length of the train ( tex2html_wrap_inline30 ). The second line of a test case contains a permutation of the numbers 1 through L, indicating the current order of the carriages. The carriages should be ordered such that carriage 1 comes first, then 2, etc. with carriage L coming last.

Output Specification

For each test case output the sentence: 'Optimal train swapping takes S swaps.' where S is an integer.

Example Input

3
3
1 3 2
4
4 3 2 1
2
2 1

Example Output

Optimal train swapping takes 1 swaps.
Optimal train swapping takes 6 swaps.
Optimal train swapping takes 1 swaps.


解析:给你一个数组,问用冒泡排序一共交换了多少次?


#include <stdio.h>
const int N = 60;
int main() {
	int t,cnt,n,tmp;
	int arr[N];
	while(scanf("%d",&t) != EOF) {
		while(t--) {
			scanf("%d",&n);
			for(int i = 0; i < n; i++) {
				scanf("%d",&arr[i]);
			}
			cnt = 0;
			for(int i = 0; i < n-1; i++) {
				for(int j = 0; j < n-i-1; j++) {
					if(arr[j] > arr[j+1]) {
						tmp = arr[j+1];
						arr[j+1] = arr[j];
						arr[j] = tmp;
						cnt++;
					}
				}
			}
			printf("Optimal train swapping takes %d swaps.\n",cnt);
		}
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值