PAT 甲级 1066 Root of AVL Tree(25 分)

1066 Root of AVL Tree(25 分)

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

 

 

 

 

Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.

 

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤20) which is the total number of keys to be inserted. Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the root of the resulting AVL tree in one line.

Sample Input 1:

5
88 70 61 96 120

Sample Output 1:

70

Sample Input 2:

7
88 70 61 96 120 90 65

Sample Output 2:

88
# include <iostream>
# include <algorithm>
using namespace std;

struct node{
	int data, height;
	node *lchild, *rchild;
};

int getheight(node *root){
	if(root == NULL) return 0;
	return root->height;
}
void updateheight(node *root){
	root->height = max(getheight(root->lchild), getheight(root->rchild)) + 1;
}
int getBalanceFactor(node *root){
	return getheight(root->lchild) - getheight(root->rchild);
}

void lrotation(node *& root){
	node *tmp = root->rchild;
	root->rchild = tmp->lchild;
	tmp->lchild = root;
	updateheight(root);
	updateheight(tmp);
	root = tmp;
}
void rrotation(node *& root){
	node *tmp = root->lchild;
	root->lchild = tmp->rchild;
	tmp->rchild = root;
	updateheight(root);
	updateheight(tmp);
	root = tmp;
}

void insert(node *& root, int data){
	if(root == NULL){
		root = new node;
		root->data = data;
		root->lchild = root->rchild = NULL;
		root->height = 1;
		return ;
	}
	if(data < root->data){
		insert(root->lchild, data);
		updateheight(root);
		if(getBalanceFactor(root) == 2){
			if(getBalanceFactor(root->lchild) == 1){
				rrotation(root);
			}
			else if(getBalanceFactor(root->lchild) == -1){
				lrotation(root->lchild);
				rrotation(root);
			}
		}
	}
	else{
		insert(root->rchild, data);
		updateheight(root);
		if(getBalanceFactor(root) == -2){
			if(getBalanceFactor(root->rchild) == -1){
				lrotation(root);
			}
			else if(getBalanceFactor(root->rchild) == 1){
				rrotation(root->rchild);
				lrotation(root);
			}
		}
	}
}

node *create(int data[], int n){
	node * root = NULL;
	for(int i = 0; i < n; i++){
		insert(root, data[i]);
	} 
	return root;
}

int main(){
//	freopen("C:\\1.txt", "r", stdin);
	node *root = NULL;
	int n, data[22];
	cin >> n;
	for(int i = 0; i < n; i++){
		cin >> data[i];
	}
	root = create(data, n);
	cout << root->data << endl;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值