hud1010回溯深度优先搜索

Tempter of the Bone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 38335    Accepted Submission(s): 10328


Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
 


 

Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter;
'S': the start point of the doggie;
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.
 


 

Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
 


 

Sample Input
  
  
4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0
 


 

Sample Output
  
  
NO YES
 

#include<iostream>
#include<cstdio>

using namespace
std;

char
map[10][10];
int
fx[4]={1,0,0,-1};
int
fy[4]={0,1,-1,0};
int
n,m;

int
dfs(int x,int y,int t)
    {

    for
(int
k=0;k<4;k++)
       {
// 4个方向行走
        int nx=x+fx[k];
        int
ny=y+fy[k];
        if
(
nx<0 || nx>=n || ny<0 || ny>=m) continue;
        if
(
t==1) // 最后一步如果能到D,则返回1,否则,就不用再继续走了
            if(map[nx][ny]=='D') return 1;
            else continue
;
        if
(
map[nx][ny]!='.') continue; // 只有 '.' 才能够行走
        map[nx][ny]='X';
        if
(
dfs(nx,ny,t-1)) return 1;
        map[nx][ny]='.';
       }

    return
0;
    }


int
main(){
    int
x,y,t,sum,zx,zy;
    while
(~
scanf("%d%d%d",&n,&m,&t))
        {

        if
(!
n) break;
        sum=1;
        for
(int
i=0;i<n;i++)
            {

             scanf("%s",map[i]);
             for
(int
j=0;j<m;j++)
                if
(
map[i][j]=='S')
                    map[i][j]='X',x=i,y=j;
                else if
(
map[i][j]=='D')
                    zx=i,zy=j;
                else if
(
map[i][j]=='.')
                    sum++;
            }

        // 两个剪枝先判断,无法在T时刻到达,直接NO
        if(t>sum || (zx-x+zy-y+t)&1) puts("NO");//(zx-x+zy-y+t)&1;判断(zx-x+zy-y+1)的最后一位是不是1,如果不是则(zx-x+zy-y+t)&1值为0
        else if
(
dfs(x,y,t)) puts("YES");
        else
puts("NO");
        }

    return
0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值