A - This is an interesting question

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:
(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l’ and weight w’ if l <= l’ and w <= w’. Otherwise, it will need 1 minute for setup.
You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are ( 9 , 4 ) , ( 2 , 5 ) , ( 1 , 2 ) , ( 5 , 3 ) , and ( 4 , 1 ) , then the minimum setup time should be 2 minutes since there is a sequence of pairs ( 4 , 1 ) , ( 5 , 3 ) , ( 9 , 4 ) , ( 1 , 2 ) , ( 2 , 5 ) .
Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1 <= n <= 5000 , that represents the number of wooden sticks in the test case, and the second line contains 2n positive integers l1 , w1 , l2 , w2 ,…, ln , wn , each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
Output
The output should contain the minimum setup time in minutes, one per line.
Sample Input
3
5
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1
Sample Output
2
1
3

首先根据出l和w从小到大排序
求w的最长下降子序列
具体证明可以参考https://www.luogu.com.cn/problem/P1020的题解
#include<iostream>
#include<algorithm>
using namespace std;
struct point{
    int l,r;
}p[5010];
bool cmp(point &x,point &y)
{
    if(x.l==y.l) return x.r<y.r;
    return x.l<y.l;
}
int xl[5010];
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int n,ans=1;
        cin>>n;
        for(int i=1;i<=n;i++) cin>>p[i].l>>p[i].r;
        sort(p+1,p+n+1,cmp);
        int con=0;
        xl[0]=1e9;
        for(int i=1;i<=n;i++)
        {
            if(p[i].r<xl[con]) xl[++con]=p[i].r;
            else
            {
                int l=1,r=con,mid=l+r>>1;
                while(l<r)
                {
                    if(xl[mid]<=p[i].r) r=mid;
                    else l=mid+1;
                    mid=l+r>>1;
                }
                xl[mid]=p[i].r;
            }
        }
        cout<<con;
        if(t) puts("");
    }

}
Beijing, the capital city of China, is a fascinating place with a rich history and culture. It's a city that has something to offer for everyone, from foodies and shoppers to history buffs and nature lovers. However, there is one place in Beijing that stands out as the most interesting and captivating: The Forbidden City. The Forbidden City is a magnificent palace complex located in the heart of Beijing. It was once the home of the imperial family during the Ming and Qing dynasties, and today it's one of the most popular tourist attractions in China. The complex covers an area of 720,000 square meters and consists of more than 800 buildings, making it the largest palace complex in the world. The Forbidden City is surrounded by a moat and a 10-meter-high wall, which adds to its grandeur and mystique. The main entrance to the palace complex is through the Meridian Gate, which is guarded by two lion statues. Once inside, visitors are transported back in time to a world of imperial splendor and opulence. The palace complex is divided into two main sections, the Outer Court and the Inner Court. The Outer Court was used for ceremonial purposes and is where the emperor would receive officials and hold important ceremonies. The Inner Court was the private residence of the imperial family and is where the emperor and his family would live. One of the most impressive buildings in the Forbidden City is the Hall of Supreme Harmony, which is located in the Outer Court. This magnificent hall was used for important ceremonies such as the coronation of emperors and the proclamation of military victories. The hall is supported by 72 wooden columns, each made from a single tree, and the roof is adorned with intricate dragon and phoenix designs. Another must-see attraction in the Forbidden City is the Palace Museum, which is located in the Inner Court. The museum houses a vast collection of imperial treasures, including jade carvings, porcelain, and ancient calligraphy. Visitors can also see the living quarters of the imperial family, including the bedrooms, living rooms, and study rooms. Overall, the Forbidden City is a must-visit destination for anyone traveling to Beijing. It's a place that captures the essence of imperial China and offers a glimpse into the ancient world of the Ming and Qing dynasties. With its grandeur, history, and cultural significance, the Forbidden City is truly the most interesting place in Beijing.
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值