《算法笔记》系列: 问题 D: 二叉树遍历

题目来源:http://codeup.cn/problem.php?cid=100000611&pid=3

题目描述

编一个程序,读入用户输入的一串先序遍历字符串,根据此字符串建立一个二叉树(以指针方式存储)。
例如如下的先序遍历字符串:
ABC##DE#G##F###
其中“#”表示的是空格,空格字符代表空树。建立起此二叉树以后,再对二叉树进行中序遍历,输出遍历结果。

输入

输入包括1行字符串,长度不超过100。

输出

可能有多组测试数据,对于每组数据,
输出将输入字符串建立二叉树后中序遍历的序列,每个字符后面都有一个空格。
每个输出结果占一行。

样例输入

a#b#cdef#####
a##

样例输出

a b f e d c 
a 
#include <iostream>
#include <cstring>
#include <fstream>
#include <string>
#include <cmath>
#include <algorithm>
#include <queue>
#include <map>

using namespace std;

struct node{
    node *L,*R;
    char x;
};

node* createNode(char x){
    node* p = new node;
    p->x=x;
    p->L=NULL;
    p->R=NULL;
    return p;
}

void buildTree(string s, int &pos, node* &p){
    if(s[pos]!='#' && pos<s.size()) {
        p=createNode(s[pos]);
        buildTree(s,++pos,p->L);
        buildTree(s,++pos,p->R);
    }
}

void Inorder(node* head){
    if(head!=NULL){
        Inorder(head->L);
        printf("%c ",head->x);
        Inorder(head->R);
    }
}

int main()
{
    string l;
    while(cin>>l) {
        int pos=0;
        node* head;
        buildTree(l,pos,head);
        Inorder(head);
        printf("\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值