1721. Gray code[Special judge]

1721. Gray code[Special judge]
 
 
Total:2124Accepted:638Rating:
2.7/5.0(12 votes)
 
   
   
 
Time Limit: 1sec    Memory Limit:32MB
Description
Gray code is an interesting code sequence and has many applications in computer science. No matter you have known it before or not, here are some introductions about its features:
(1)Gray code has 2 n unique elements;
(2)Each element contains n digits of 0 or 1;
(3)Each pair of adjacent elements has exactly one different digit.
For example, when n=2, one of the gray code sequences is: 00,01,11,10.
Now, the task is quite simple, given a positive integer n, generate the corresponding Gray code sequence.
Input
Input may contain multiple test cases. Each test case consists of one positive integer n(n<=16), Input is terminated by a case with n=0, which should not be processed.
Output
For each test case, output the corresponding Gray code sequence, one element per line. There may be multiple answers, any of them will be accepted. Please output a blank line after each test case.
Sample Input
Copy sample input to clipboard
1
2
0
Sample Output
0
1

00
01
11
10
// Problem#: 1721
// Submission#: 2001703
// The source code is licensed under Creative Commons Attribution-NonCommercial-ShareAlike 3.0 Unported License
// URI: http://creativecommons.org/licenses/by-nc-sa/3.0/
// All Copyright reserved by Informatic Lab of Sun Yat-sen University
#include<iostream>
#include<cmath>
#include<stdio.h>
#include<string>


using namespace std;


void change(char *p,int n){
    p[n-1]+=1;
    int i=0;
    while(p[n-1-i]>='2'){
        p[n-1-i]-=2;
        p[n-2-i]+=1;
        i++;
    }


}
void haha(char *p,char *q,int n){
    int i;
    q[0]=p[0];
    for(i=1;i<n;i++){
        q[i]=(p[i-1]-'0')^(p[i]-'0')+'0';
    }
}
int main(){
    int n;
    while(cin>>n&&n!=0){
        char *p=new char[n+1];
         char *q=new char[n+1];
        int i;
        p[n]='\0';
        q[n]='\0';
        for(i=0;i<n;i++){
            p[i]='0';
            q[i]='0';
        }
        for(i=0;i<pow(2,n);i++){
            int x;
            printf("%s\n",q);
            change(p,n);
            haha(p,q,n);
            
        }
        printf("\n");
    }
    return 0;
}             
用printf输出,而且必须转化成     题目要求的字符串,而不是简单的加一。               
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
大学生就业服务平台管理系统按照操作主体分为管理员和用户。管理员的功能包括学生档案管理、字典管理、试卷管理、试卷选题管理、试题表管理、考试记录表管理、答题详情表管理、错题表管理、法律法规管理、法律法规收藏管理、法律法规留言管理、就业分析管理、论坛管理、企业管理、简历管理、老师管理、简历投递管理、新闻资讯管理、新闻资讯收藏管理、新闻资讯留言管理、学生信息管理、宣传管理、学生管理、职位招聘管理、职位收藏管理、招聘咨询管理、管理员管理。用户的功能等。该系统采用了Mysql数据库,Java语言,Spring Boot框架等技术进行编程实现。 大学生就业服务平台管理系统可以提高大学生就业服务平台信息管理问题的解决效率,优化大学生就业服务平台信息处理流程,保证大学生就业服务平台信息数据的安全,它是一个非常可靠,非常安全的应用程序。 管理员权限操作的功能包括管理新闻信息,管理大学生就业服务平台信息,包括考试管理,培训管理,投递管理,薪资管理等,可以管理新闻信息。 考试管理界面,管理员在考试管理界面中可以对界面中显示,可以对考试信息的考试状态进行查看,可以添加新的考试信息等。投递管理界面,管理员在投递管理界面中查看投递种类信息,投递描述信息,新增投递信息等。新闻信息管理界面,管理员在新闻信息管理界面中新增新闻信息,可以删除新闻信息。新闻信息类型管理界面,管理员在新闻信息类型管理界面查看新闻信息的工作状态,可以对新闻信息的数据进行导出,可以添加新新闻信息的信息,可以编辑新闻信息信息,删除新闻信息信息。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值