1150. 简单魔板

1150. 简单魔板

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB , Special Judge

Description

魔板由8个大小相同方块组成,分别用涂上不同颜色,用18的数字表示。

其初始状态是

1 2 3 4

8 7 6 5

对魔板可进行三种基本操作:

A操作(上下行互换):

8 7 6 5

1 2 3 4

B操作(每次以行循环右移一个):

4 1 2 3

5 8 7 6

C操作(中间四小块顺时针转一格):

1 7 2 4

8 6 3 5

用上述三种基本操作,可将任一种状态装换成另一种状态。

Input

输入包括多个要求解的魔板,每个魔板用三行描述。

第一行步数N不超过10的整数),表示最多容许的步数。

第二、第三行表示目标状态,按照魔板的形状,颜色用18的表示。

当N等于-1的时候,表示输入结束。

Output

对于每一个要求解的魔板,输出一行。

首先是一个整数M,表示你找到解答所需要的步数。接着若干个空格之后,从第一步开始按顺序给出M步操作(每一步是ABC),相邻两个操作之间没有任何空格。

注意:如果不能达到,则M输出-1即可。

Sample Input

45 8 7 64 1 2 338 7 6 51 2 3 4-1

Sample Output

2 AB1 A评分:M超过N或者给出的操作不正确均不能得分。

Problem Source

ZSUACM Team Member


下午一哥么问的,然后临时写的代码,第一次很傻逼的 road[100],因为之前用过一次结构体里面的数组是100,懒得改,结果运行内存超过了。然后改成10就好了。

首先是暴力枚举了m个A,B,C的排列组合的所有种可能,然后逐个对比进行模拟操作,知道找到与符合的操作输出或者所有的排列组合都模拟完输出-1。

题目之所以变的容易解的原因是所有满足m步以内且能够变换成功的都算答案正确,而并不要求最简单的变换。


#include<iostream>

#include<vector>


using namespace std;


struct way{
    char road[10];
};
std::vector<way>myway;


int m;


int begi[2][4]={1,2,3,4,8,7,6,5};


void A(int **a){
int x;
for(x=0;x<4;x++){
int temp;
temp=a[0][x];
a[0][x]=a[1][x];
a[1][x]=temp;
}
}
void B(int **a){
int x;
int temp=a[0][3];
for(x=3;x>0;x--){
a[0][x]=a[0][x-1];
}
a[0][0]=temp;
temp=a[1][3];
for(x=3;x>0;x--){
a[1][x]=a[1][x-1];
}
a[1][0]=temp;
}
void C(int **a){
int temp=a[1][1];
a[1][1]=a[1][2];
a[1][2]=a[0][2];
a[0][2]=a[0][1];
a[0][1]=temp;
}
bool com(int **a,int begi[][4]){
int x,y;
for(x=0;x<2;x++){
for(y=0;y<4;y++){
if(a[x][y]!=begi[x][y]){
return false;
}
}
}
return true;
}








void enume(char Next,int num,char *ans){
    int i;
    if(num==m){
        way temp_Way;
        for(i=0;i<num;i++){
            temp_Way.road[i]=ans[i];
        }
        myway.push_back(temp_Way);
    }
    else{
        char *ans1=new char[num+1];
char *ans2=new char[num+1];
char *ans3=new char[num+1];
for(i=0;i<num;i++){
ans1[i]=ans[i];
ans2[i]=ans[i];
ans3[i]=ans[i];
}
ans1[i]=Next;
ans2[i]=Next;
ans3[i]=Next;
enume('A',num+1,ans1);
enume('B',num+1,ans2);
enume('C',num+1,ans3);
    }
}


int main(){
while(cin>>m&&m!=-1){
myway.empty();
int **temp=new int*[2];
   temp[0]=new int[4];
temp[1]=new int[4];
int x,y;
char ans[1];
enume('A',0,ans);
enume('B',0,ans);
enume('C',0,ans);
for(x=0;x<2;x++){
for(y=0;y<4;y++){
cin>>temp[x][y];
}
}
int i;
int flag=0;
for(i=0;i<myway.size();i++){
for(x=0;x<m;x++){
if(myway[i].road[x]=='A'){
A(temp);
}
else if(myway[i].road[x]=='B'){
B(temp);
}
else{
C(temp);
}
if(com(temp,begi)){
cout<<x+1<<' ';
int t;
for(t=0;t<m;t++){
cout<<myway[i].road[t];
}
cout<<endl;
flag=1;
break;
}


}
if(flag){
break;
}
}
if(flag==0){
cout<<'-1'<<endl;
}
}
}
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值