并查集 HDOJ1856 More is better

More is better

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 327680/102400 K (Java/Others)
Total Submission(s): 15566    Accepted Submission(s): 5733


Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex,  the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
 

Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
 

Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep. 
 

Sample Input
  
  
4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8
 

Sample Output
  
  
4 2
Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect), then A and C are also friends(indirect). In the first sample {1,2,5,6} is the result. In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.
 


并查集简单题,找出节点最多的一棵树。
这个题需要注意的细节是当t==0的时候,应该输出的男孩子个数为1。


#include <cstdio>

int num[10000010], use[10000010];

int find_set(int x)     //路径压缩
{
    if(x==num[x])   return x;
    num[x]=find_set(num[x]);
    return num[x];
}

int main()
{
    int t, n, m, mmax;
    while(scanf("%d",&t)!=EOF)
    {
        if(t==0)    //注意的细节
        {
            printf("1\n");
            continue;
        }
        for(int i=0;i<=10000001;i++)
        {
            num[i]=i;
            use[i]=1;
        }
        mmax=0;
        while(t--)
        {
            scanf("%d%d",&n,&m);
            int p=find_set(n);
            int q=find_set(m);
            if(p!=q)        //注意的地方!因为这里WA了无数次,以前将判断条件写成了n!=m,实际上应该是若两个节点的父节点不同才会进行路径压缩
            {
                num[q]=find_set(p);
                use[find_set(p)]+=use[q];   //将子节点的孩子个数加到父节点上,并将子节点孩子个数重置为零
                use[q]=0;
            }
            if(use[p]>mmax) mmax=use[p];
        }
        printf("%d\n",mmax);
    }
    return 0;
}


  
  
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值