HDOJ 1856 More is better(并查集)

More is better




Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex,  the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
 

Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
 

Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep. 
 

Sample Input
  
  
4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8
 

Sample Output
  
  
4 2
题目大意:房间里有10000000个男孩,编号从1到10000000。一共有n次操作,每次操作指定2个男孩成为朋友(直接的或间接的),问有朋友关系的男孩最多有几个。

解题思路:利用并查集维护男孩之间的关系,rank[i]保存以i为根节点的集合内有多少男孩。注意n=0时输出1。

代码如下:

#include <bits/stdc++.h>
const int maxn = 100005;
const int maxm = 10000005;
int par[maxm],rank[maxm];
int a[maxn],b[maxn];
void init(int n)
{
	for(int i = 1;i <= n;i++){
		par[i] = i;
		rank[i] = 1;
	}
}

int find(int x)
{
	return par[x] == x ? x : par[x] = find(par[x]);
}

void unite(int x,int y)
{
	x = find(x);
	y = find(y);
	if(x == y)
		return ;
	par[y] = x;
	rank[x] += rank[y];
	rank[y] = 1;
}

bool same(int x,int y)
{
	return find(x) == find(y);
}

int main()
{
	int n;
	while(scanf("%d",&n) != EOF){
		int mx = 1;
		for(int i = 0;i < n;i++){
			scanf("%d %d",&a[i],&b[i]);
			mx = std::max(mx,std::max(a[i],b[i]));
		}
		init(mx);
		for(int i = 0;i < n;i++){
			unite(a[i],b[i]);
		}
		int ans = 0;
		for(int i = 1;i <= mx;i++){
			ans = std::max(rank[i],ans);
		}
		printf("%d\n",ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值