PAT 1065. A+B and C (64bit) (20)

Given three integers A, B and C in [-263, 263], you are supposed to tell whether A+B > C.

Input Specification:

The first line of the input gives the positive number of test cases, T (<=10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line "Case #X: true" if A+B>C, or "Case #X: false" otherwise, where X is the case number (starting from 1).

Sample Input:
3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0
Sample Output:
Case #1: false
Case #2: true
Case #3: false
大数,,,直接用Java干!
import java.math.BigInteger;
import java.util.Scanner;
class Main
{
	public static void main(String[] args)
	{
		Scanner in = new Scanner(System.in);
		int n = in.nextInt();
		for(int i = 1; i <= n; i++)
		{
			String s1 = in.next();
			String s2 = in.next();
			String s3 = in.next();
			BigInteger a = new BigInteger(s1);
		    BigInteger b = new BigInteger(s2);
		    BigInteger c = new BigInteger(s3);
		    if(a.add(b).compareTo(c) == 1)
		    	System.out.printf("Case #%d: true\n",i);
		    else
		    	System.out.printf("Case #%d: false\n",i);
		}
	}
}

也写了个c++版本,java太占内存了惹..
#include <iostream>
#include <string>
#include <vector>
using namespace std;
int main()
{
  int n;
  cin>>n;
  for(int k = 1; k <= n; k++)
  {
    string s1,s2,s3,s4;
    cin>>s1>>s2>>s3;
    vector<int> a,b;
    for(int i =s1.size()-1; i >= 0; i--)
      a.push_back(s1[i]-'0');
    for(int i = s2.size()-1; i >= 0; i--)
      b.push_back(s2[i]-'0');
    vector<int> c;
    int rest = 0;
    int i;
    for(i = 0; i < min(a.size(),b.size()); i++)
    {
      c.push_back((a[i]+b[i]+rest)%10);
      rest = (a[i]+b[i]+rest)/10;
    }
    for(; i < a.size(); i++)
    {
      c.push_back((a[i]+rest)%10);
      rest = (a[i]+rest)/10;
    }
    for(; i < b.size(); i++)
    {
      c.push_back((b[i]+rest)%10);
      rest = (b[i]+rest)/10;
    }
    if(rest != 0)
      c.push_back(rest);
    for(int j = c.size()-1; j >= 0; j--)
      s4 += static_cast<char>(c[j]+'0');
    while(s4.size() > s3.size()) s3 = '0' + s3;
    while(s3.size() > s4.size()) s4 = '0' + s4;
    if(s4 > s3)
      cout<<"Case #"<<k<<": true"<<endl;
    else
      cout<<"Case #"<<k<<": false"<<endl;
  }
  return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值